End audio/video stream when device is removed during usage

RESOLVED DUPLICATE of bug 1272588

Status

()

P2
normal
Rank:
29
RESOLVED DUPLICATE of bug 1272588
3 years ago
3 years ago

People

(Reporter: kozlovalexandr, Unassigned)

Tracking

unspecified
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0
Build ID: 20160502172042

Steps to reproduce:

1. Establish WebRTC call in FireFox using some external USB camera
2. Remove USB camera from PC (during active call)


Actual results:

Picture freezes, JS application does not receive any event, looks like FireFox do nothing


Expected results:

I think JS code should receive 'onended' event for stream and/or video track.
Just to compare: Google Chrome even reload page in such cases.

P.S. I understand that it's unusual situation, but please fix this when you will have time.
:jib: do you happen to know:
- if we have bug report for this already somewhere?
- if we even get notified in C++ land about such a device removal (I guess this might depend on the platform)?
Status: UNCONFIRMED → NEW
backlog: --- → webrtc/webaudio+
Rank: 29
Ever confirmed: true
Flags: needinfo?(jib)
Priority: -- → P2
onended support is about to land in bug 1208373, and this seems to be a dup of bug 1272588.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(jib)
Resolution: --- → DUPLICATE
Duplicate of bug: 1272588
You need to log in before you can comment on or make changes to this bug.