Unable to send signed messages

VERIFIED WORKSFORME

Status

P2
normal
VERIFIED WORKSFORME
17 years ago
10 years ago

People

(Reporter: mscott, Assigned: kaie)

Tracking

({regression})

1.0 Branch
psm2.2
x86
Windows 2000
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I just downloaded todays bits: 2002022203. When I try to send a signed message I
get an alert dialog while we are assembling the message saying: 

"Sending of message failed. Please verify that your account settings are correct."

I can send encrypted messages just fine. The problem is only with signed messages. 

I think this bug has two issues we should look at:

1) figure out why signed messages aren't working
2) figure out a way to have a security specific warning here instead of the
generic check your account settings.
(Reporter)

Comment 1

17 years ago
I wonder if we should nominate this for .9.9 unless I'm the only one whose
having trouble...
Keywords: nsbeta1, regression

Comment 2

17 years ago
S/MIME
Assignee: kaie → ssaux
Component: Security: General → S/MIME
Product: MailNews → PSM
QA Contact: junruh → alam
Version: other → 2.2

Comment 3

17 years ago
It worked fine for me using 2002022203 build on WinNT.
(Assignee)

Comment 4

17 years ago
Trying to test that with my own build (a couple of days old), it worked.

I fetched today's sources and made a depend build.

On first attempt, I saw your problem.
On second attempt I crashed.

After a full clobber rebuild, everything worked.

Either this is meanwhile fixed, or the build you used was a broken depend build.
Ian Mcgreer told me, he believes NSS is not doing depend builds correctly.

Scott, are you still seeing the problem?
(Reporter)

Comment 5

17 years ago
Using a release build from: 2002022503 (yesterday), I still see this problem.
Encrypted is working fine still. Just signed messages. Very strange. They are
both using the same cert.
(Assignee)

Comment 6

17 years ago
That could be a problem local to your certificate database.

Maybe the crypto engine is refusing to use your cert for signing. You could try
to use certificate manager and look at the details of your own cert, whether it
is listed as verified/valid etc. for both signing and encrypting.

Obviously the status feedback to the user on crypto failure is not good enough
yet. See also bug 121287 for another example of this.

Comment 7

17 years ago
I think this bug might be a duplicate for the one I just
sent in, 129936.  Sorry about that.

Comment 8

17 years ago
This must be fixed.
kai.
Assignee: ssaux → kaie
Priority: -- → P2
Target Milestone: --- → 2.2

Comment 9

17 years ago
Marking fixed. Sending signed mail works for me.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
QA Contact: alam → junruh
Resolution: --- → FIXED
(Reporter)

Comment 10

17 years ago
re-opening.

there is no patch attached to this bug. Why do you think it's fixed? 

Using 2002030908, I still have the same problem I described before. Encrypted
works great, signing is still failing. Both use the same cert. I used this cert
before to send signed messages.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 11

17 years ago
John just came by my cube to help me figure out what's going on. Some how my
cert manager lost the trusted state for GTE Corporation. This caused my cert to
no longer be verified. Putting the trusts back on this cert fixed the problem.

This is the same profile I've used since netscape 6.0 so I'm not sure how it
lost the trust information, but I won't complain. Thanks John!
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 12

17 years ago
Filed bug 131087

Comment 13

17 years ago
Verified worksforme.
Status: RESOLVED → VERIFIED

Updated

14 years ago
Component: Security: S/MIME → Security: S/MIME
Product: PSM → Core

Updated

11 years ago
Version: psm2.2 → 1.0 Branch

Updated

10 years ago
Component: Security: S/MIME → Security: S/MIME
Product: Core → MailNews Core
QA Contact: junruh → s.mime
You need to log in before you can comment on or make changes to this bug.