Detaching a tab while playing live AirMo stream results in broken video.

RESOLVED DUPLICATE of bug 1275687

Status

()

Core
Audio/Video: Playback
RESOLVED DUPLICATE of bug 1275687
2 years ago
2 years ago

People

(Reporter: Dolske, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8753538 [details]
Screencast of glitch

I detached a tab playing a live AirMo stream, and the resulting window just had a white rectangle where the video should be. It's still playing (I hear audio), but there's no video now. Further, reloading the tab (reload / shift-reload) still has a visually-broken video, as does opening a new tab (in that window). Opening a new tab with the video in the original window works fine.

I suspect this might be hidpi and/or APZ related -- when I scroll the page, I get a glitchy little box over the video showing other parts of the page, and it scrolls oddly.
(Reporter)

Comment 1

2 years ago
(I can't reproduce this with YouTube or a standalone video file, just airmo.)

Updated

2 years ago
Component: Audio/Video → Audio/Video: Playback
Is it reproducible and can you provide STR? What version of Firefox are you using? Can you paste in the graphics section of about:support ?
(Reporter)

Comment 3

2 years ago
This was on a current(ish) OS X Nightly. I can't reproduce it at the moment (due to nothing streaming, and recorded AirMo sessions work fine), but will try next time there's a stream. I saw this at least once before, a few weeks ago, so it's not entirely a one-off glitch.

Features
Compositing	OpenGL
Asynchronous Pan/Zoom	wheel input enabled
WebGL Renderer	NVIDIA Corporation -- NVIDIA GeForce GT 750M OpenGL Engine
Hardware H264 Decoding	Yes
GPU #1
Active	Yes
Vendor ID	0x10de
Device ID	0x0fe9
Diagnostics
AzureCanvasAccelerated	1
AzureCanvasBackend	skia
AzureContentBackend	skia
AzureFallbackCanvasBackend	none
Richard - what is special about live streams?
Flags: needinfo?(richard)
OS: Unspecified → Mac OS X
(Reporter)

Comment 5

2 years ago
Created attachment 8755542 [details]
prefs.js

Yeah, I'm able to reliably reproduce this on my MBP, tested on today's AirMo stream.

Curiously, this only happens in my regular Firefox profile. Not a new profile. But if I copy over my prefs.js to the new profile, it then reproduces. So it seems to be something in there...

I kept chopping away at my prefs.js to see what it might be, and got as far as this before today's project meeting on AirMo ended.

The last test I was able to do was deleting 10 prefs, starting with browser.sessionstore.upgradeBackup.latestBuildID. That made the stream work, but none of those 10 prefs seem at all relevant to anything involving gfx/video, so I suspect that's a red herring.

My basic procedure was:

1) Copy badprefs.js to prefs.js
2) Delete some stuff from it
3) Copy prefs.js to temp.js
4) Try to reproduce
5) If repro'd, copy temp.js to badprefs.js and repeat
(Reporter)

Comment 6

2 years ago
Steps to reproduce:

1) Start browser
2) Open air.mozilla.org, start watching a live stream
3) Make sure there's at least one other tab in the window
4) Select the AirMo tab, drag it downwards to detach it

ER: Audio/Video continues playing normally
AR: Audio playing, video is black box with weird gfx glitches on scrolling
(In reply to Anthony Jones (:kentuckyfriedtakahe, :k17e) from comment #4)
> Richard - what is special about live streams?

I confirmed it happens in Dev edition as well.  

FYI there is a live test stream available 24/7.  Look for the Browser Test Page link in the right sidebar of the home page. (Attaching an image).

...yes these are recordings, but they are running through our live stream workflow.

Live streams are HLS streams through Akamai's CDN.  They consist of a playlist.m3u8, a chunklist.m3u8 and mediasegment.ts files for each 10 seconds of video at 4 different resolutions/bitrates.   The current HLS player in use on AirMo is CLAPPR.  (https://github.com/clappr/clappr).

Adding Peter the AirMo WebDev to the conversation for more insight.
Flags: needinfo?(richard) → needinfo?(peterbe)
Unable to reproduce. I went to https://air.mozilla.org/browser-test-stream/ and dragged that tab out so it becomes its own window. Worked fine.
Flags: needinfo?(peterbe)
Ok.  I'm confused.  It's working fine me now as well.
Jean-Yves - any ideas on what this would've been or why it disappeared?
Flags: needinfo?(jyavenard)
Because of bug 1275687 maybe?
Flags: needinfo?(jyavenard)
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1275687
You need to log in before you can comment on or make changes to this bug.