Change 'restore' behaviour after aero snap to diverge from 'normal' Windows behaviour

VERIFIED INVALID

Status

()

Core
Widget: Win32
P4
enhancement
VERIFIED INVALID
a year ago
a year ago

People

(Reporter: straightupandup, Unassigned)

Tracking

46 Branch
Unspecified
Windows
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0
Build ID: 20160502172042

Steps to reproduce:

Press WinKey+right arrow or left arrow, click maximize window, click restore window.


Actual results:

Firefox is not restored to where it was.


Expected results:

Restore size as it was before clicking maximize.

Note: I realize this is Windows wide, but would be nice if firefox used a custom restore to fix this bad behavior, or guess should submit this to Microsoft but can imagine the bureaucracy, yet can't imagine why this would be by design, but can imagine that's what they're gonna tell me :)

Updated

a year ago
Component: Untriaged → Widget: Win32
OS: Unspecified → Windows
Product: Firefox → Core
(Reporter)

Updated

a year ago
Severity: normal → enhancement
Component: Widget: Win32 → General
OS: Windows → Windows 7
Priority: -- → P4
Hardware: Unspecified → x86_64
(Reporter)

Updated

a year ago
Component: General → General
Product: Core → Firefox
(Reporter)

Updated

a year ago
Component: General → Widget: Win32
OS: Windows 7 → Windows
Product: Firefox → Core
Hardware: x86_64 → Unspecified
(Reporter)

Comment 1

a year ago
sorry YF thought u were telling me to make corrections lol
This is how Windows' aero snap works. Other people will expect the current behaviour even if you don't. We shouldn't change OS default behaviour just for Firefox. Talk to MS about it, not us. The "Windows Insider" program for Windows 10 provides good avenues for feedback like this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
Status: RESOLVED → VERIFIED
Summary: Window restore icon misbehaves → Change 'restore' behaviour after aero snap to diverge from 'normal' Windows behaviour
(Reporter)

Comment 3

a year ago
ok thanks sorry for wasting anyones time :/
You need to log in before you can comment on or make changes to this bug.