Fullscreen is broken in Firefox 46 and xmonad (with EwmhDesktops and fullscreenEventHook enabled)

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
2 years ago
2 years ago

People

(Reporter: bdowning, Unassigned)

Tracking

({regression})

46 Branch
x86_64
Linux
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160412225428

Steps to reproduce:

1. Start Firefox 46 in my xmonad configuration, which includes XMonad.Hooks.EwmhDesktops and has fullscreenEventHook enabled.
2. Press F11


Actual results:

The navigation bar animates off the top of the screen as expected in fullscreen, but the window size does not change; it stays tiled.


Expected results:

The window should have grown to fill the whole screen.  This was the behavior for me in all Firefoxes up until 46.  (Confirmed by downgrading to 45 and seeing fullscreen work.)

With fullscreenEventHook enabled I never had the problems described in bug 1189622; fullscreen always worked perfectly for me with both web pages and fullscreen video, and I never had any video update problems.  Assuming it was this patch which changed the behavior to what I'm seeing, this has regressed from previous behavior for xmonad users which have the fullscreen hook configured.
(Reporter)

Comment 1

2 years ago
Created attachment 8753660 [details]
A minimal xmonad.hs that demonstrates the bug

Here's a minimal xmonad.hs that will demonstrate the bug on Firefox 46, and demonstrate working fullscreen on Firefox 45.
(Reporter)

Comment 2

2 years ago
(Ignore the myEwmh stuff, that was leftover cruft from my actual xmonad config that I forgot to remove, it has no bearing on the issue here.)
(Reporter)

Updated

2 years ago
OS: Unspecified → Linux
Hardware: Unspecified → x86_64

Comment 3

2 years ago
46 supports Gtk3 now.
Blocks: 627699
Component: Untriaged → Widget: Gtk
Product: Firefox → Core
(Reporter)

Comment 4

2 years ago
For information, evince's F11 fullscreen works correctly on this xmonad configuration, and it is using GTK3:

:; ldd =evince | grep gtk
        libgtk-3.so.0 => /usr/lib/libgtk-3.so.0 (0x00007fcc77c02000)
What does "xprop -root _NET_SUPPORTED" print?
(Reporter)

Comment 6

2 years ago
:; xprop -root _NET_SUPPORTED
_NET_SUPPORTED(ATOM) = _NET_SUPPORTING_WM_CHECK, _NET_WM_NAME, _NET_WM_STATE_HIDDEN, _NET_NUMBER_OF_DESKTOPS, _NET_CLIENT_LIST, _NET_CLIENT_LIST_STACKING, _NET_CURRENT_DESKTOP, _NET_DESKTOP_NAMES, _NET_ACTIVE_WINDOW, _NET_WM_DESKTOP, _NET_WM_STRUT
Thanks.  The missing _NET_WM_STATE_FULLSCREEN is the way for the window manager to indicate that fullscreen windows are not supported.

Since changes for bug 1189622, Gecko doesn't request fullscreen windows when they are not supported by the window manager.  That is the correct behavior AIUI.

If fullscreenEventHook is adding support for fullscreen windows, then it should modify _NET_SUPPORTED and _NET_WM_ALLOWED_ACTIONS appropriately.

https://specifications.freedesktop.org/wm-spec/1.5/ar01s03.html#idm139870830098752
https://specifications.freedesktop.org/wm-spec/1.5/ar01s05.html#idm139870829966672
Blocks: 1189622
No longer blocks: 627699
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Keywords: regression
Resolution: --- → WONTFIX
Sounds like something needs to be fixed from xmond side.
(Reporter)

Comment 9

2 years ago
Thanks for the information, I'll look into seeing what it takes to fix up XMonad.Hooks.EwmhDesktops.
See Also: → bug 1279634
You need to log in before you can comment on or make changes to this bug.