Setting a breakpoint in the Browser Toolbox makes opening the regular Toolbox hit the slow script dialog

RESOLVED DUPLICATE of bug 1269457

Status

RESOLVED DUPLICATE of bug 1269457
3 years ago
5 months ago

People

(Reporter: pbro, Unassigned)

Tracking

({regression})

Trunk
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
I'm on Windows 10, last fx-team update: 49.0a1 (2016-05-17)

STR:
- open a tab on https://www.mozilla.org/en-US/
- open the webconsole once so the scripts load
- close the webconsole
- now open the Browser Toolbox
- open console-output.js in the debugger tab of the Browser Toolbox
- set a breakpoint in the Messages.BaseMessage constructor (this also happen with other panels and other scripts, as long as there's a breakpoint)
- now come back to the browser tab and open the console

In my case the browser becomes unresponsive for ~30 seconds, or even (in some cases) shows the "slow script" dialog, until it finally loads the UI of the console and the breakpoint is hit.
(Reporter)

Comment 1

3 years ago
This didn't use to happen, so flagging as a regression, although I don't know when this started to happen.
I've witnessed this over the past 2 or 3 days.
Keywords: regression
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1269457
Removing tracking flag since we will track in the Duplicate bug in Comment 2.
status-firefox49: affected → ---

Updated

5 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.