Building Firefox from latest fx-team results in a broken browser

RESOLVED DUPLICATE of bug 1274253

Status

()

Firefox
Build Config
RESOLVED DUPLICATE of bug 1274253
2 years ago
2 years ago

People

(Reporter: bsilverberg, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Platform: OS X 10.11.4

I just pulled from fx-team and when I do an artifact build the resulting Firefox crashes as soon as you try to interact with it (i.e., click anywhere). The error message I see in the console is:

[Child 12329] ###!!! ABORT: Aborting on channel error.: file /builds/slave/fx-team-m64-000000000000000000/build/src/ipc/glue/MessageChannel.cpp, line 2050

I have tried clobbering as well as completely removing the build folder and the artifact cache folder, but the results are always the same.

I am currently trying a full (non-artifact) build and will report back when that is finished.
(Reporter)

Comment 1

2 years ago
I just finished my full build and the problem has gone away, so it seems like it's an issue with the artifact build.
Bob, can you upload a full log of the build output that produces the broken build?
(Reporter)

Comment 3

2 years ago
Well, after doing a full build, and that resulting in a working browser, I then changed back to generating an artifact build so I could produce a log of the full output, but now that is working too. So I am afraid that I cannot provide a log of a build that generates a broken browser as I am now no longer able to reproduce that.

If nobody else is seeing the issue I guess we can close it as invalid.
Created attachment 8754013 [details]
build.log

I do have the same problem than Bob. Here's the log of the build
Ok, thanks. We always use the most recently built binaries for an artifact build, so there's a known issue where pulling certain changes that don't have corresponding binaries built at that revision yet will result in a broken build (due to incompatibility between the local changes and the built binaries). With this log we might be able to pinpoint the change and figure out how to handle this better.

A workaround that should be reliable is to base local work on a revision that already has builds finished in automation.
Nicolas, just to confirm, that exact log resulted in a broken build? According to it, it's finding the builds for the working parent, which means if that build is broken there's another problem. I'll attempt to reproduce when I get access to a macbook, but I can't when I attempt on linux.
(In reply to Chris Manchester (:chmanchester) from comment #6)
> Nicolas, just to confirm, that exact log resulted in a broken build?
> According to it, it's finding the builds for the working parent, which means
> if that build is broken there's another problem. I'll attempt to reproduce
> when I get access to a macbook, but I can't when I attempt on linux.

Yes. If i then do `./mach run`, the console output a single line (`/fx-team/objdir-frontend/dist/Nightly.app/Contents/MacOS/firefox -no-remote -foreground -profile /Users/nicolaschevobbe/Projects/fx-team/objdir-frontend/tmp/scratch_user`), and then the process stops. Appending '-v' does not provide additional information
Is there some news on this ? I pulled from fx-team approx. 1 hour ago and still can't run (even after removing objdir-frontend)
When I try to run the build app, I got : `illegal hardware instruction`
I attempted to reproduce this issue from the revision mentioned in the log in comment 4 on my macbook last night, but the resulting build worked fine.

Does doing a regular build (without --enable-artifact-builds in your mozconfig) from the same revision result in a working build?
I'll try it, it just takes a lot more times ( 90 minutes ). That's why I love Artifact build so much
Someone was asking about something similar on irc earlier... another thing to check would be if the current nightly works on your machine.
I just noticed bug 1274253, this may be a dupe.
I did a full build from a local commit on top of revision a3eb9950fa4b, and I still have the same error. I looked at the other bugs, and tried the fixed build, which works. I'm putting this bug as dupe, thanks for the help !
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1274253
You need to log in before you can comment on or make changes to this bug.