Closed Bug 1274017 Opened 4 years ago Closed 4 years ago

Incomplete about:support when WebGL is disabled

Categories

(Firefox :: General, defect, minor)

49 Branch
x86
Windows
defect
Not set
minor

Tracking

()

VERIFIED FIXED
Firefox 49
Tracking Status
firefox48 --- verified
firefox49 --- verified

People

(Reporter: wip.the.gruik, Assigned: dvander)

References

Details

Attachments

(3 files)

Mozilla/5.0 (Windows NT 5.1; rv:49.0) Gecko/20100101 Firefox/49.0
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:49.0) Gecko/20100101 Firefox/49.0

Reproducible with Firefox 49.0 on Windows XP and Nightly 49.0-x64 on Windows 7.

Steps to reproduce:
 - in about:config, set the property "webgl.disabled" to "true" 
 - go to about:support

Actual results:
 end of page sections like "JavaScript", "Accessibility" or "Library Versions" are empty

Expected results:
 all sections including "JavaScript", "Accessibility" and "Library Versions" should contain values

The browser console displays 2 errors when opening about:support :
 "Error: WebGL: Failed to create WebGL context: WebGL is currently disabled.  Troubleshoot.jsm:434:12"
 "TypeError: Argument 1 of Node.appendChild is not an object.  aboutSupport.js:592:25"
I suspect this is a duplicate of bug 1272820 (or at least also regressed from bug 1263849). :dvander, can you take a look?
Flags: needinfo?(dvander)
See Also: → 1272820
Sounds likely, will look tomorrow.
Assignee: nobody → dvander
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Flags: needinfo?(dvander)
Attached patch fixSplinter Review
Extra properties that we haven't explicitly printed get dumped into a table. I didn't notice that some of these properties are formatted as an array which must be localized, so we were throwing an exception trying to format them.
Attachment #8754536 - Flags: review?(milan)
Attachment #8754536 - Flags: review?(milan) → review+
https://hg.mozilla.org/mozilla-central/rev/a1cda9db9b8e
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 49
Duplicate of this bug: 1272820
[Tracking Requested - why for this release]: bug 1274017 was tracked and it ended up getting fixed here.
Comment on attachment 8754536 [details] [diff] [review]
fix

Approval Request Comment
[Feature/regressing bug #]: bug 1263849
[User impact if declined]: Broken about:support; half the page doesn't render.
[Describe test coverage new/current, TreeHerder]: Nightly
[Risks and why]: Low risk. Not taking this makes it harder to offer support or diagnostics to users whom the bug affects. 
[String/UUID change made/needed]:
Attachment #8754536 - Flags: approval-mozilla-aurora?
Comment on attachment 8754536 [details] [diff] [review]
fix

Improve the feedback, taking it
Attachment #8754536 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
I have reproduced this bug on Nightly 49.0a1 (2016-05-18) on Ubuntu 16.04 LTS, 64 bit!

The bug's fix is now verified on Latest Aurora 48.0a2!

Build ID: 20160603004101
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:48.0) Gecko/20100101 Firefox/48.0

Also the bug’s fix is now verified on Latest Nightly 49.0a1!

Build ID: 20160602030220
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:49.0) Gecko/20100101 Firefox/49.0
QA Whiteboard: [testday-20160603]
I have reproduced this bug with nightly 49.0a1 (2016-05-18) on windows 10, 32 bit.

The bug’s fix is now verified on Latest Nightly 50.0a1 and Latest Aurora 49.0a2.

Build ID:20160709030233.
User Agent:Mozilla/5.0 (Windows NT 10.0; rv:50.0) Gecko/20100101 Firefox/50.0.

Build ID:20160710004020.
User Agent:Mozilla/5.0 (Windows NT 10.0; rv:49.0) Gecko/20100101 Firefox/49.0.

[testday-20160708]
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.