folder with extended chars doesn't work

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
17 years ago
10 years ago

People

(Reporter: raphael.barazzutti, Assigned: Bienvenu)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020223
BuildID:    20020223

i've a folder called Véronique. I saw it as V?ronique.
i renamed manually the file to Veronique and it works. I renamed after the
folder name to Véronique using the frontend and after a mozilla reboot the
problem was back

Reproducible: Always
Steps to Reproduce:
1.rename a folder to a name with a "é","è",...
2.reboot mozilla
3.try to access it

Comment 1

17 years ago
Hi, i guess you mean 'restart' mozilla ;)

Tested it with 2002020415 (yes.. old build) on Linux 2.4.17.

I renamed
'Mozilla Project' to 'Mözilla Projéct', restarted, renamed the folder back to
Mozilla Project, restarted again.. no problem..

But:
Mozilla does weired things with the bookmarks.html in the profiles directory.

'Mözilla' should be 'Mözilla' (imho) in the HTML Source of bookmarks.htm,
but it is: 'Mözilla'

but: mozilla doesn't seam to like something like '&ouml' into the
bookmarks.html. ö isn't displayed as an 'ö' in the bookmarks menue, it's
displayed as ö..

Comment 2

17 years ago
aint this a dupe of bug 41944 ?

Comment 3

16 years ago
can you please try with a current build ?
many changes to this code, special chars WFM now

Comment 4

16 years ago
Raphaël Barazzutti wrote:

Hi!
I tried with current build. it works, I was able to rename the folder
from "Veronique" to "Véronique" without having problem after restarting 
mozilla.
--------------
reslving WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.