Closed Bug 127419 Opened 18 years ago Closed 18 years ago

build warning in nsDefaultSOAPEncoder.cpp

Categories

(SeaMonkey :: General, defect)

x86
Linux
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: Biesinger, Assigned: Biesinger)

References

Details

Attachments

(1 file)

nsDefaultSOAPEncoder.cpp produces a build warning ("p may be used uninitialized
in this function" or similar), and this may actually be a bug. I'll attach a
patch in a second; rayw, please review.
This is correct.  r=rayw
Comment on attachment 71076 [details] [diff] [review]
patch

sr=jst
Attachment #71076 - Flags: superreview+
Attachment #71076 - Flags: review+
Comment on attachment 71076 [details] [diff] [review]
patch

a=asa (on behalf of drivers) for checkin to the 1.0 trunk
Attachment #71076 - Flags: approval+
checked in
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → FIXED
*** Bug 127489 has been marked as a duplicate of this bug. ***
Bug 59652 is a general tracking bug for "xxx might be used uninitialized" warnings.

The warning indeed went away on TBox (see
http://tinderbox.mozilla.org/SeaMonkey/warn1015455480.9882.html), so marking
verified.
Blocks: 59652
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.