Highlights item brought from queue after a delete, is wrongly replaced at refresh by a related page of the deleted item

RESOLVED INVALID

Status

()

Firefox
Activity Streams: General
RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: VladB, Unassigned)

Tracking

Trunk
x86_64
All
Points:
---

Firefox Tracking Flags

(firefox49 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8754343 [details]
remove from highlights.mp4

[Affected versions]:
- Firefox 45.0 and up
- Activity Stream 1.0.17

[Affected Platforms]:
- All Windows
- All Mac OS
- All Linux

[Prerequisites]:
- Latest Activity Stream add-on version (1.0.17) was previously installed on a profile.
- Have more more history so that the "Highlights" area is populated with visited websites.
- Visit multiple articles from the same hostmane(eg. multiple articles from www.bbc.com) and wait between 30 minutes and 1 hour, so that at least one of the visited articles to be added to "Highlights" area.

[Steps to reproduce]:
1. Start Firefox browser with the profile where Activity Stream add-on was previously installed.
2. Hover the mouse cursor over the article from prerequisites that it is displayed in "Highlights" area.
3. Click on "X" button and remove it from History.
4. Observe the Highlights area.
5. Refresh the Timeline.
6. Observe again the Highlights area.

[Expected results]:
4. Next item from Highlights queue is displayed.
6. Same 3 articles are displayed in Highlights after refresh. 

[Actual results]:
4. Next item from Highlights queue is displayed.
6. The item that has been brought from queue is replaced by an item that belongs to the same hostname as the deleted one.
(Reporter)

Comment 2

2 years ago
This behaviour was verified with latest Nightly 50.0a1 (Build ID: 20160607030217) using Activity Stream v1.0.19-dev and it is working as intended for now.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.