TEST-UNEXPECTED-ERROR | test_direct_update.py TestDirectUpdate.test_update | MarionetteException: MarionetteException: win.document.documentElement is null

RESOLVED DUPLICATE of bug 1268087

Status

Testing
Firefox UI Tests
RESOLVED DUPLICATE of bug 1268087
2 years ago
2 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

({intermittent-failure})

49 Branch
intermittent-failure
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

2 years ago
07:24:53     INFO - TEST-START | test_direct_update.py TestDirectUpdate.test_update

 07:24:54     INFO -  MARIONETTE LOG: INFO: TEST-START: c:\jenkins\workspace\mozilla-aurora_update\build\tests\firefox-ui\tests\update\direct\test_direct_update.py:test_update

 07:24:54     INFO -  *** AUS:SVC Creating UpdateService

 07:24:55     INFO -  console.error: PushService:

 07:24:55     INFO -    stateChangeProcessEnqueue: Error transitioning state

 07:24:55     INFO -    UnknownError

 07:24:58     INFO - TEST-UNEXPECTED-ERROR | test_direct_update.py TestDirectUpdate.test_update | MarionetteException: MarionetteException: win.document.documentElement is null

 07:24:58     INFO - Traceback (most recent call last):

 07:24:58     INFO -   File "c:\jenkins\workspace\mozilla-aurora_update\build\venv\lib\site-packages\marionette\marionette_test.py", line 351, in run

 07:24:58     INFO -     testMethod()

 07:24:58     INFO -   File "c:\jenkins\workspace\mozilla-aurora_update\build\tests\firefox-ui\tests\update\direct\test_direct_update.py", line 20, in test_update

 07:24:58     INFO -     self.download_and_apply_available_update(force_fallback=False)

 07:24:58     INFO -   File "c:\jenkins\workspace\mozilla-aurora_update\build\venv\lib\site-packages\firefox_ui_harness\testcases.py", line 301, in download_and_apply_available_update

 07:24:58     INFO -     about_window = self.browser.open_about_window()

 07:24:58     INFO -   File "c:\jenkins\workspace\mozilla-aurora_update\build\venv\lib\site-packages\firefox_puppeteer\ui\browser\window.py", line 225, in open_about_window

 07:24:58     INFO -     return BaseWindow.open_window(self, callback, AboutWindow)

 07:24:58     INFO -   File "c:\jenkins\workspace\mozilla-aurora_update\build\venv\lib\site-packages\firefox_puppeteer\ui\windows.py", line 376, in open_window

 07:24:58     INFO -     window = self._windows.create_window_instance(new_handle, expected_window_class)

 07:24:58     INFO -   File "c:\jenkins\workspace\mozilla-aurora_update\build\venv\lib\site-packages\firefox_puppeteer\ui\windows.py", line 108, in create_window_instance

 07:24:58     INFO -     self.switch_to(handle)

 07:24:58     INFO -   File "c:\jenkins\workspace\mozilla-aurora_update\build\venv\lib\site-packages\firefox_puppeteer\ui\windows.py", line 202, in switch_to

 07:24:58     INFO -     return self.create_window_instance(target_handle)

 07:24:58     INFO -   File "c:\jenkins\workspace\mozilla-aurora_update\build\venv\lib\site-packages\firefox_puppeteer\ui\windows.py", line 112, in create_window_instance

 07:24:58     INFO -     message='Cannot get window type for chrome window handle "%s"' % handle

 07:24:58     INFO -   File "c:\jenkins\workspace\mozilla-aurora_update\build\venv\lib\site-packages\marionette_driver\wait.py", line 122, in until

 07:24:58     INFO -     rv = condition(self.marionette)

 07:24:58     INFO -   File "c:\jenkins\workspace\mozilla-aurora_update\build\venv\lib\site-packages\firefox_puppeteer\ui\windows.py", line 111, in <lambda>

 07:24:58     INFO -     lambda mn: mn.get_window_type(),

 07:24:58     INFO -   File "c:\jenkins\workspace\mozilla-aurora_update\build\venv\lib\site-packages\marionette_driver\marionette.py", line 1462, in get_window_type

 07:24:58     INFO -     return self._send_message("getWindowType", key="value")

 07:24:58     INFO -   File "c:\jenkins\workspace\mozilla-aurora_update\build\venv\lib\site-packages\marionette_driver\decorators.py", line 36, in _

 07:24:58     INFO -     return func(*args, **kwargs)

 07:24:58     INFO -   File "c:\jenkins\workspace\mozilla-aurora_update\build\venv\lib\site-packages\marionette_driver\marionette.py", line 757, in _send_message

 07:24:58     INFO -     self._handle_error(err)

 07:24:58     INFO -   File "c:\jenkins\workspace\mozilla-aurora_update\build\venv\lib\site-packages\marionette_driver\marionette.py", line 818, in _handle_error

07:24:58 INFO - raise errors.lookup(error)(message, stacktrace=stacktrace)
(Reporter)

Updated

2 years ago
Keywords: intermittent-failure
(Reporter)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1268087
You need to log in before you can comment on or make changes to this bug.