Closed Bug 1274495 Opened 5 years ago Closed 5 years ago

Animated node glitches when 3D transform applied to several nodes

Categories

(Core :: Graphics: Layers, defect)

46 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1269321
Tracking Status
firefox46 --- wontfix
firefox47 --- wontfix
firefox48 - wontfix
firefox49 - fixed
firefox-esr38 --- unaffected
firefox-esr45 --- unaffected
firefox50 --- fixed

People

(Reporter: roland, Assigned: mattwoodrow)

References

()

Details

(Keywords: regression)

To make the report easier, I have create a video walk through to show you the issue what came with Firefox 46. Before that Firefox worked fine for this case. (video slowed down at some parts to show the bug)

Video: https://www.youtube.com/watch?v=hBSdTY_jkqs&feature=youtu.be

Live test: http://smartslider3.com/city/

When you go over this page, you can see that the "city" is animated. You should watch the "colored houses", and the "shadow houses" images in the background. 

Also on the bottom left side with the bench and the trees the z-index produce glitches.

On the second and the third slide the background should getting darker and dark and it fills up in the whole area, but in Firefox it display only just the bottom right part of it. When CSS transform property removed, it looks fine again, but I think it is a bug.

Tested in Firefox 46 and Firefox 46.0.1 on Windows 7 and Windows 8.1 on multiple video cards.
Via local build,
Last Good: 885889d182fd
First Bad: 7e18014be68d

Triggered by: 7e18014be68d	Matt Woodrow — Bug 1168263 - Add nsDisplayPerspective and build separate layers for perspective. r=roc
There is some inconsistent tagging of bugs, where it looks like bug 1168263 landed in 45, but it was backed out in 45 Aurora, so it only rode the train to release with 46.
Assignee: nobody → matt.woodrow
Flags: needinfo?(matt.woodrow)
I spend a little bit time to look into it.  The problem is perspective on the container of all sprites.  I try to disable perspective in inspector.  It looks good.  It seems to be sorted in wrong order for some reason.
Wontfix for 46/47 at this point, too late for a fix.
Tracking for 48/49 since this is still a recent regression.
This looks to be a duplicate of bug 1269321, my patch there fixes it.
Flags: needinfo?(matt.woodrow)
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1269321
You need to log in before you can comment on or make changes to this bug.