Full screen mode does not follow platform defaults for titlebar

RESOLVED EXPIRED

Status

RESOLVED EXPIRED
17 years ago
9 years ago

People

(Reporter: bzbarsky, Assigned: jag+mozilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Full screen mode puts minimize/restore/close buttons in that order on the far
right.  While this is indeed the "Windows Way", many windowmanagers on Linux
have different default settings.  Also, on the Mac the close button is on the
_left_ while the others are on the right.

Since scripts in unpriveleged content can start full screen mode, this can lead
to user confusion as the user tries to find the close button to kill this damn
window that's taking up all the space all of a sudden.

I feel that the buttons should be in a platform overlay at the very least, with
the default Windows arrangement being as is and the default Mac arrangement
following the Mac convention.

For Linux, I think the best solution is to fix bug 127444 and then not show any
buttons at all in the chrome.

Comment 1

17 years ago
This implementation was only intended for Windows, are you seeing it on Linux (I
don't have my Linux box handy), or just thinking ahead?  If it is exposed on
Linux, the most we would do for MachV is disable it, and then only if it was
causing some serious problem.
I should clarify.  This is fullscreen mode gotten by doing

window.fullScreen = true;

from a script.  One can do this by hand by typing

javascript:void(window.fullScreen = true)

in the url bar.  There is no UI on Linux that I can see for starting this full
screen mode if a user wants to, but web content can start full screen mode (bug
127405).

That said, the current implementation on Linux is actually pretty good (I've
been playing with it) and I would be in favor of having it turned on but made
inaccessible to untrusted content.
Product: Core → Mozilla Application Suite
Assignee: hewitt → jag
QA Contact: bugzilla

Comment 3

10 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 4

9 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but still has no comment since the inception of the SeaMonkey project 5 years ago.

Because of this, we're resolving the bug as EXPIRED.

If you still can reproduce the bug on SeaMonkey 2 or otherwise think it's still valid, please REOPEN it and if it is a platform or toolkit issue, move it to the according component.

Query tag for this change: EXPIRED-20100420
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → EXPIRED
You need to log in before you can comment on or make changes to this bug.