Closed Bug 1274551 Opened 4 years ago Closed 9 months ago

Build Menu API allowing to specify target (anchor)

Categories

(DevTools :: Framework, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1563686

People

(Reporter: Honza, Unassigned)

References

(Blocks 1 open bug)

Details

HTML Menu API introduced in bug 1257613 should allow to specify target (anchor) for popup menus. Just like it was possible for XUL menus see: 
https://developer.mozilla.org/en-US/docs/Mozilla/Tech/XUL/Method/openPopup

This is a follow up for bug 1266419

Honza
This shouldn't be added to the Menu API directly, so we can match as closely as possible to the Electron spec.  We could add a wrapper for the API that calls into it though.
Severity: normal → enhancement
Product: Firefox → DevTools

Will fix this in Bug 1563686

Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1563686
You need to log in before you can comment on or make changes to this bug.