Crash when when typing special characters in the URL bar on IOS 8.x

RESOLVED WONTFIX

Status

()

--
critical
Rank:
8
RESOLVED WONTFIX
3 years ago
2 years ago

People

(Reporter: SimonB, Assigned: sleroux)

Tracking

({crash, reproducible})

unspecified
Other
iOS
crash, reproducible

Firefox Tracking Flags

(fxios-v5.0 affected, fxios-)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8754819 [details]
Crash log of the issue.

Build: 57cc05c7
Device: IPhone 4S ( 8.4)

Steps to reproduce:
1. Open a new tab in Firefox
2. Type @[. in the URL bar and tap go

Actual results: 
- The application will crash.
Severity: normal → critical
Keywords: crash, reproducible

Comment 1

3 years ago
Please note that Mozilla's mobile browser does not and has never owned a gmail account.
Rank: 8
tracking-fxios: ? → 5.0+
(Assignee)

Updated

3 years ago
Assignee: nobody → sleroux
Status: NEW → ASSIGNED
(Assignee)

Comment 2

3 years ago
After playing around a bit with this, it seems the main point of contention with the @[. url is the square bracket [. There is a great discussion in this SO post [1] talking specifically about the square brackets and other reserved characters and how they affect a URL being valid. Since this only occurs on iOS 8 and not 9, it would seem they've addressed this bug inside WebKit. As for a fix for Firefox, ideally we would treat this kind of input as a search instead of a URL but our current way of validating URLs by using NSURL says it's a valid URL. This falls into the area of validating URLs ourselves since square brackets are definitely acceptable in other parts of a URL. I don't think filtering URLs through a regex would be worth the potentially trouble to fix a bug on a low adoption iOS version. I would remove this from 5.0+ -> + unless there is a neat fix we can do to change this to return searches instead of URLs.

[1] http://stackoverflow.com/questions/1547899/which-characters-make-a-url-invalid
(Reporter)

Comment 3

3 years ago
Alternate steps to reproduce on IOS 9.x :

1. Go to Firefox for desktop and add some bookmarks
2. Edit one of the bookmarks on desktop by right click and entering properties 
3. Type in the URL field [@. which will default to http://%5B@./
4. Sync Firefox on desktop and mobile device
5. Go to the bookmark location on mobile device and scroll to the edited bookmark
tracking-fxios: 5.0+ → -
(Assignee)

Comment 4

2 years ago
Closing as we no longer support 8.x
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.