Closed Bug 1274587 Opened 3 years ago Closed 3 years ago

Execute custom javascript method fails

Categories

(Testing :: Marionette, defect, P3)

x86_64
Windows
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1123506

People

(Reporter: mariia.saburova, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/50.0.2661.102 Safari/537.36

Steps to reproduce:

You should have custom js commands in your site. In our it is "pf"
1. Execute script via Selenium webdriver framework (in ruby: browser.execute_script("return pf"))



Actual results:

pf is not defined
"ReferenceError: pf is not defined (WARNING: The server did not provide any stacktrace information)\nCommand duration or timeout: 6 milliseconds\nBuild info: version: '2.53.0', revision: '35ae25b', time: '2016-03-15 17:00:58'\nSystem info: host: 'Konf1', ip: '10.100.2.105', os.name: 'Windows 7', os.arch: 'amd64', os.version: '6.1', java.version: '1.8.0_31'\nDriver info: org.openqa.selenium.firefox.MarionetteDriver\nCapabilities [{rotatable=false, raisesAccessibilityExceptions=false, appBuildId=20160502172042, version=46.0.1, platform=XP, proxy={}, specificationLevel=1, acceptSslCerts=false, browserVersion=46.0.1, platformVersion=6.1, XULappId={ec8030f7-c20a-464f-9b0e-13a3a9e97384}, browserName=Firefox, takesScreenshot=true, takesElementScreenshot=true, platformName=Windows_NT, device=desktop}]\nSession ID: cb81b018-bd3d-4e03-aa89-fa8031895bf0 (org.openqa.selenium.WebDriverException)"


Expected results:

Script should be executed.
In previous versions on Firefox without Marionette is was executed and in other browsers too.
In Firefox console it is executed too.
OS: Unspecified → Windows
Priority: -- → P3
Hardware: Unspecified → x86_64
The evaluate script subsystem had a major overhaul in bug 1123506 which will be available in Firefox 49. Can you try again with Nightly to see if the problem persists?
Flags: needinfo?(mariia.saburova)
(In reply to Andreas Tolfsen ‹:ato› from comment #1)
> The evaluate script subsystem had a major overhaul in bug 1123506 which will
> be available in Firefox 49. Can you try again with Nightly to see if the
> problem persists?

It isn't reproduced with Nightly 49.0a1. Thanks.
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Flags: needinfo?(mariia.saburova)
Resolution: --- → DUPLICATE
Duplicate of bug: 1123506
(In reply to mariia.saburova from comment #2)
> (In reply to Andreas Tolfsen ‹:ato› from comment #1)
> > The evaluate script subsystem had a major overhaul in bug 1123506 which will
> > be available in Firefox 49. Can you try again with Nightly to see if the
> > problem persists?
> 
> It isn't reproduced with Nightly 49.0a1. Thanks.
> 
> *** This bug has been marked as a duplicate of bug 1123506 ***

Great!

FWIW automatedtester plans to backport bug 1123506 to Aurora and possibly Beta.
You need to log in before you can comment on or make changes to this bug.