Firefox sometimes misses resize-events when maximized during start-up by window manager (GTK3)

RESOLVED DUPLICATE of bug 1251217

Status

()

Core
Widget: Gtk
RESOLVED DUPLICATE of bug 1251217
2 years ago
2 years ago

People

(Reporter: Clemens Eisserer, Unassigned)

Tracking

({regression})

47 Branch
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gfx-noted])

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8754887 [details]
firefox_missed_resize_event.png

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160516123243

Steps to reproduce:

Opened Firefox with a few saved Tabs.


Actual results:

Although the window was maximised (automatically by the window manager?), firefox somehow missed the resize and ~150px on the right side remained black (screenshot attached).
Forcing a repaint by opening new tabs or scrolling did not help, only resizing the window helped to fix the issue.

I have seen this behaviour now a few times after the switch to GTK3, with the GTK2 backend I've never experienced this behaviour.


Expected results:

Firefox should corrently notice when the window is maximized - even if it is automatically (immediatly after the window is shown).
(Reporter)

Updated

2 years ago
Summary: Firefox sometimes musses resize-events (GTK3) → Firefox sometimes misses resize-events (GTK3)

Comment 1

2 years ago
I am not seeing this in GTK3. Can you still able to reproduce in clean profile and safe-mode?
Component: Untriaged → Graphics
Flags: needinfo?(linuxhippy)
Product: Firefox → Core
(Reporter)

Comment 2

2 years ago
as mentioned this behaviour only happens from time-to-time, most likely triggered by interaction between firefox and the window-manager (in my case xfwm). Somehow lookslike a race-condition somewhere.

I don't see how a clean profile of safe-mode would influence missed resize-events.
Keywords: regression
Whiteboard: [gfx-noted]
I doubt this is a graphics bug.
It may be a problem handling events from GTK, or 
perhaps an issue due to Gecko mixing up size notifications and size requests,
similar to bug 888164.
Component: Graphics → Widget: Gtk
See Also: → bug 1251217
Summary: Firefox sometimes misses resize-events (GTK3) → Firefox sometimes misses resize-events when maximized during start-up by window manager (GTK3)
Thanks for the report.
I think this is most likely caused by the same fault as bug 1251217 and there is some analysis there.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
See Also: bug 1251217
Duplicate of bug: 1251217

Updated

2 years ago
Flags: needinfo?(linuxhippy)
You need to log in before you can comment on or make changes to this bug.