Returns in executeScript via Marionette

RESOLVED DUPLICATE of bug 1123506

Status

()

defect
RESOLVED DUPLICATE of bug 1123506
3 years ago
3 years ago

People

(Reporter: matt, Unassigned)

Tracking

47 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_4) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/52.0.2738.0 Safari/537.36

Steps to reproduce:

Load a page and wait for a variable to be set on the window object within that page using selenium-webdriver (This is from node).

driver.get(url)
.then(() => {
   // We get webdriver to wait until window.testsuite.testResults is defined.
   // This is set in the in browser mocha tests when the tests have finished
    // successfully
    return driver.wait(function() {
      return driver.executeScript('return window.testsuite;');
    });
});

I've added wires to my path and telling firefox to use marionette with:

const ffOptions = new firefoxOptions.Options();
ffOptions.useMarionette(true);

return new webdriver
      .Builder()
      .forBrowser(this.getSeleniumBrowserId())
      .setFirefoxOptions(ffOptions)
      .build();


Actual results:

window.testsuite is always null, even when I check the console and print window.testsuite directly in the developer tools and see that it's not.


Expected results:

It should return the object stored in window.testsuite.
I suspect this is a duplicate of bug 1123506.  Can you verify with Nightly that this is fixed?
Flags: needinfo?(matt)
Completely right, seems to be working on nightly - missed it due to tests stalling on a different issue with Firefox :(

Thanks for following up.
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Flags: needinfo?(matt)
Resolution: --- → DUPLICATE
Duplicate of bug: 1123506
You need to log in before you can comment on or make changes to this bug.