Print custom size Scale dialog always needs a new and different value entered.

RESOLVED FIXED in Firefox 57

Status

()

RESOLVED FIXED
2 years ago
a year ago

People

(Reporter: cjg.aptl, Assigned: bobowen)

Tracking

45 Branch
mozilla57
Points:
---

Firefox Tracking Flags

(firefox57 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160502160818

Steps to reproduce:

Load a page.  
Select Print (goes to print preview page)
On size drop-down box, select "Custom"
There is likely to be a value already entered, say 75(%). Do not change this value.
Hit return to "use" this entered value


Actual results:

The scale displayed does not change, stays on previously used scale (e.g. shrink to fit)


Expected results:

It should display at the pre-existing scale value present.

-----

In order to get the page to display at a custom scale, you have to enter a value, which must be different from the pre-existing value, then it works.

So if you often use a particular scale (say 75%), you have to enter a different value (say 74%), hit return, then select the scale and enter the value you want (75%).

Long winded for what should respond on the original "return"/ "OK" exit from the dialog

Updated

2 years ago
Component: Untriaged → Print Preview
Product: Firefox → Core
(Assignee)

Comment 1

a year ago
Created attachment 8904506 [details] [diff] [review]
Use previous custom scale value when switching from Shrink To Fit in Print Preview

The change here is to make the prompt return the value even if it hasn't changed,
because we still need to reprocess if we are switching from Shrink To Fit.
(Assignee)

Updated

a year ago
Assignee: nobody → bobowencode
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Updated

a year ago
Attachment #8904506 - Flags: review?(dtownsend)
Attachment #8904506 - Flags: review?(dtownsend) → review?(mconley)
Comment on attachment 8904506 [details] [diff] [review]
Use previous custom scale value when switching from Shrink To Fit in Print Preview

Review of attachment 8904506 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!
Attachment #8904506 - Flags: review?(mconley) → review+

Comment 3

a year ago
Pushed by bobowencode@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/ad3316ee67aa
Use previous custom scale value when switching from Shrink To Fit in Print Preview. r=mconley

Comment 4

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/ad3316ee67aa
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
status-firefox57: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
You need to log in before you can comment on or make changes to this bug.