Status

()

defect
--
major
RESOLVED DUPLICATE of bug 1232045
3 years ago
3 years ago

People

(Reporter: yknetg, Unassigned)

Tracking

({regression})

42 Branch
x86_64
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

3.92 MB, video/webm
Details
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:46.0) Gecko/20100101 Firefox/46.0
Build ID: 20160502172042

Steps to reproduce:

Open the attached webm video file with Firefox.


Actual results:

Firefox can't play the video. Chrome and VLC can play it.


Expected results:

Firefox can play the webm video file.
Oops, the file is too large to attach. Please wait a while.
Posted video bug.webm
Only firefox can't play this video.
Severity: normal → critical
OS: Unspecified → Mac OS X
Priority: -- → P1
Hardware: Unspecified → x86_64
I remember that firefox also can play the video until mid of 2015.
So, I think this issue is regression.
Severity: critical → major
Component: Untriaged → Audio/Video: Playback
Priority: P1 → --
Product: Firefox → Core
It regressed by bug 1185792:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=bdb808a2dd6668a083f4bb9aa5ea69302f5e182b&tochange=195776f0148b0594f655170ee0a49361a1a4592e

In 49, playback has been fixed by bug 1232045, but Firefox changes the video resolution at various timestamps (like 00:00-00:05). Is it normal? 
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=98fd214bd3f2c3f6b78484c8c19a5f7c84aca880&tochange=1fc001760e73deabb9c2114bd88876be3699a0b8
Blocks: 1185792
Depends on: 1232045
Flags: needinfo?(jyavenard)
Keywords: regression
Version: 46 Branch → 42 Branch
Seconding the above. Think this is fixed in nightly, and see it working for me locally in nightly.
I don't see how it could have been regressed by bug 1185792 however, as I don't believe the old WebMReader supported resolution change.
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Flags: needinfo?(jyavenard)
Resolution: --- → DUPLICATE
Duplicate of bug: 1232045
You need to log in before you can comment on or make changes to this bug.