Crash while downloading pdf

RESOLVED DUPLICATE of bug 1274752

Status

()

Core
Widget: Gtk
RESOLVED DUPLICATE of bug 1274752
2 years ago
2 years ago

People

(Reporter: Timvde, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox49 affected)

Details

(Reporter)

Description

2 years ago
I'm not sure if the files being a pdf is significant, but I had two crashes today while downloading a file.

This report is for the first crash. Nightly crashed *as soon as* I started downloading. The file had been created on my disk, but was 0 bytes.

I filed bug 1274752 for the other crash, this might be a duplicate, but I filed twice because of the slightly different conditions and the different stack trace.

https://crash-stats.mozilla.com/report/index/08a77286-bae8-456d-bdad-b28802160521
I've updated gtk3 package to gtk3-3.20.5-2 (Arch Linux) and Firefox doesn't crash anymore.

Comment 3

2 years ago
@Timvde: Which Linux distribution and exact gtk3 version is this about?
(Reporter)

Comment 4

2 years ago
I'm on Arch, just like Alexander. At the time of crash, I was on gtk3-3.20.5-1. I could reproduce the crash (https://crash-stats.mozilla.com/report/index/257f3f43-5d14-48a0-afdc-56f412160522, I don't remember if that was the website from this bug or bug 1274752). I just updated to 3.20.5-2, and the crash is gone. Can we conclude that this was a GTK bug, and resolve WFM?

Comment 5

2 years ago
(In reply to Timvde from comment #4)
> I was on gtk3-3.20.5-1.
> I just updated to 3.20.5-2, and the crash is gone.

If -2 includes https://git.gnome.org/browse/gtk+/commit/?h=gtk-3-20&id=ca8d51e6d0f78cc170cc212dd7ef6664d2e662f4 that might be https://bugzilla.gnome.org/show_bug.cgi?id=766694
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1274752
You need to log in before you can comment on or make changes to this bug.