firefox illegal instruction (0x4) crash during startup on OS 10.10

RESOLVED DUPLICATE of bug 1274253

Status

()

Firefox
Build Config
RESOLVED DUPLICATE of bug 1274253
2 years ago
2 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

42 Branch
Unspecified
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8755431 [details]
Apple crash report

I have seen various disconnects from Marionette for our Firefox ui tests recently on OS X, which turned out to be a start-up crash due to an illegal instruction. So far this is happening for mozilla-central builds only.

$ build/FirefoxNightly.app/Contents/MacOS/firefox
Illegal instruction: 4

Thread 0 crashed with X86 Thread State (64-bit):
  rax: 0x0000000000000000  rbx: 0x00000001053fbae0  rcx: 0x0000000000000000  rdx: 0x00000000bfebfbff
  rdi: 0x0000000000000000  rsi: 0x000000000000000d  rbp: 0x00007fff5a8155b0  rsp: 0x00007fff5a8155b0
   r8: 0x00007fff65f73660   r9: 0x00007fff7a472300  r10: 0x000060000007e6e0  r11: 0x00007fff79c010f0
  r12: 0x000000010541b458  r13: 0x00007fff65f73598  r14: 0x00007fff65f7aa98  r15: 0x0000000000000000
  rip: 0x00000001053fbb66  rfl: 0x0000000000010246  cr2: 0x00007fff7a70b0c0
  
Logical CPU:     1
Error Code:      0x00000000
Trap Number:     6

The full log from the Apple Crash reporter is attached.
(Reporter)

Comment 1

2 years ago
Actually this is fixed in most recent builds on OS X. A check for the regression range showed me bug 1274253 which got this right again.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1274253
You need to log in before you can comment on or make changes to this bug.