Closed Bug 1274992 Opened 4 years ago Closed 4 years ago

talos: use talos-powers to allow tests to focus the content - instead of globally at pageloader

Categories

(Testing :: Talos, defect)

defect
Not set

Tracking

(firefox49 fixed)

RESOLVED FIXED
mozilla49
Tracking Status
firefox49 --- fixed

People

(Reporter: avih, Assigned: avih)

References

(Blocks 1 open bug)

Details

(Whiteboard: [talos_wishlist])

Attachments

(2 files, 2 obsolete files)

Quick recap:

1. At bug 1254898 (add talos video composition test) we found out that we need to focus the content before we start the test or else the test hangs.

2. At bug 1266181 we solved 1 by making the pageloader focus the content on all pageloader tests.

3. Solution 2 proved to cause regressions on some tests.

Which brings us to this bug: Instead of always focusing the content, add talos-powers functionality which allows the test itself to focus the content.

The video test will use this functionality, and we'll backout the global focus which was added at bug 1266181.
Duplicate of this bug: 1264325
We advance the pageloader version and not reverting it back to 1.0.5 because AMO will not sign the same version again, and if we revert to 1.0.5, then the next time someone updates the pageloader and will use 1.0.6 - AMO will refuse to sign it.
Attachment #8755457 - Flags: review?(jmaher)
Attachment #8755456 - Flags: review?(jmaher) → review+
Comment on attachment 8755457 [details] [diff] [review]
bug1274992.part2.patch - revert bug 1266181 but advance pageloader-version

Review of attachment 8755457 [details] [diff] [review]:
-----------------------------------------------------------------

just remember to resign the pageloader addon and commit that as well.
Attachment #8755457 - Flags: review?(jmaher) → review+
Carrying r+, updated talos-powers version from 1.07 to 1.08 and signed the xpi.
Attachment #8755456 - Attachment is obsolete: true
Attachment #8755541 - Flags: review+
Carrying r+, updated pageloader version from 1.0.6 to 1.0.7 and signed the xpi.
Attachment #8755457 - Attachment is obsolete: true
Attachment #8755543 - Flags: review+
Keywords: checkin-needed
(In reply to Carsten Book [:Tomcat] from comment #8)
> backed this out in 
> https://treeherder.mozilla.org/#/jobs?repo=mozilla-
> inbound&revision=ae4b9e58a98a seems this or the other talos change caused
> https://treeherder.mozilla.org/logviewer.html#?job_id=28541751&repo=mozilla-
> inbound

This specific flake8 issue is from the other talos change at bug 1264325, but I will do a try push of this to make sure it's clean before I land it. Thanks.
Flags: needinfo?(avihpit)
Try push looks good.
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/5567b666d2c3
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla49
Depends on: 1277545
You need to log in before you can comment on or make changes to this bug.