Closed Bug 1275014 Opened 4 years ago Closed 4 years ago

decision task should output an artifact containing final taskids

Categories

(Firefox Build System :: Task Configuration, task)

task
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1274611

People

(Reporter: dustin, Assigned: dustin)

References

Details

All of the artifacts produced currently are indexed by task label, not taskId.  I'd prefer to leave the labels in there, for ease of comparison, but *something* needs to link taskIds to task labels for later comparison with what was actually executed.

I'm not sure which would be better: a JSON object of the tasks actually created, indexed by label; or an artifact containing just a mapping from task label to taskid.
bug 1274611 implements this
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1274611
Product: TaskCluster → Firefox Build System
You need to log in before you can comment on or make changes to this bug.