text-align:right causing form elements to dissapear in fieldset

RESOLVED WORKSFORME

Status

()

Core
Layout: Form Controls
P2
normal
RESOLVED WORKSFORME
16 years ago
15 years ago

People

(Reporter: Chris Casciano, Assigned: rods (gone))

Tracking

({css1, testcase})

Trunk
Future
css1, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPME[CSS1-5.4.6], URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
In the linked document there should be a select control and a submit button in
the upper right corner of the page. The following few slight adaptations show
that text-align:right on either the DIV or the FIELDSET elements are causing the
elements contained to vanish.

http://www.neuralust.com/~cac6982/index_moz_1.html
This is identical to the document showing the error, except that I have placed a
border on the DIV#stylechooser that contains the form elements that i want
aligned. In this test case text-align is set on the FIELDSET element.

http://www.neuralust.com/~cac6982/index_moz_2.html
Removing text-align:right from the FIELDSET element causes the form elements to
display properly.

http://www.neuralust.com/~cac6982/index_moz_3.html
Placing text-align:right in the DIV instead shows the same problem

... and just to proove i'm not totally crazy:

http://www.neuralust.com/~cac6982/index_moz_4.html
This document uses the same external CSS file as index_moz_1.html, but I've
added a paragraph inside the fieldset and all three elements (select, p &
submit) magically appear.

[all documents validate both xhtml 1.0 strict and css at w3.org & the behavior
is seen on 0.9.8 on both my win2k box & my OSX box & the latest OSX nightly] 


[NOTE: black on black link text in the linked document is intentional and NOT a
symptom of this bug]
(Reporter)

Comment 1

16 years ago
Going back over some of my other work with this document I see that I am loosing
the submit button here (with text-align:center)

http://www.neuralust.com/~cac6982/index.php?sheet=04
->Form Controls
Assignee: asa → rods
Component: Browser-General → HTML Form Controls
QA Contact: doronr → madhur

Comment 3

16 years ago
Happens w/ build: 2002022503  OS: WinME
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 4

16 years ago
probably a dup
Status: NEW → ASSIGNED
Priority: -- → P1
Summary: text-align:right causing form elements to dissapear → text-align:right causing form elements to dissapear in fieldset
Whiteboard: DUPME
Target Milestone: --- → Future
(Assignee)

Comment 5

16 years ago
Created attachment 71526 [details]
small testcase with fieldset
Keywords: css1, testcase
Whiteboard: DUPME → DUPME[CSS1-5.4.6]
(Assignee)

Updated

15 years ago
Priority: P1 → P2

Updated

15 years ago
QA Contact: madhur → tpreston
(Reporter)

Comment 6

15 years ago
Revisiting my bugs in 1.0 and recent trunk builds... confirming this is still a
problem
(Reporter)

Comment 7

15 years ago
3 months later and still not a word on this...

*begins wondering if anyones listening at this point*
All the testcases work for me in linux trunk build 2002-10-25-08.  Please retest
with a current trunk build?
(Reporter)

Comment 9

15 years ago
sorry for the lack of response... i've been busy working on other projects...
Looking through the test cases with both Chimera 2002122004 and Moz 1.3b/OS X

All linked pages seem to work fine in 1.3b although the bug still exists in the
Chimera build (which is quite some time after Boris checked on the linux
trunk)... so either the bug did get fixed in the time between these two builds
or the bug is slowly getting fixed from platform to platform... I'm not deep
enough in this project to figure this out quickly
Chris, Chimera builds off the 1.0 branch, not off the trunk.  So it's picked up
very few of the fixes that have gone in since early May 2002....  ;)

Marking workforme if this works in a trunk build for you.
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.