Log viewer should auto-load the first log step for successful jobs

RESOLVED FIXED

Status

Tree Management
Treeherder: Log Viewer
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

Details

If you have a successful job and want to check details in the log viewer, you will notice that no log output is shown in the log viewer. You have to click on a step first before the log is getting loaded.

https://treeherder.mozilla.org/logviewer.html#?job_id=1110443&repo=mozilla-beta#L0-L949
Yeah that would be more useful than the current behaviour. Tweaking the summary slightly since I thought it meant something else initially.

This would just need a small tweak to the current handling, which only deals with the error case:
https://github.com/mozilla/treeherder/pull/1379
Summary: Log viewer does not initially load log for successful jobs → Log viewer should auto-load the first log step for successful jobs
We used to, in https://github.com/mozilla/treeherder/pull/828. Something must have regressed, but the log contents now seem to load on a successful job.

However every successful job I've tried today seems to have a reboot skipped and unnamed step in it, and logviewer is scrolling to the bottom on load, rather than (I assume in a clean result) loading the first line.
Fixed by bug 1315808 (on stage, will likely be deployed to prod tomorrow).
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1315808
Depends on: 1315808
Resolution: DUPLICATE → FIXED
You need to log in before you can comment on or make changes to this bug.