WebExtensions: chrome.windows.create does not work correctly if 'type' is 'popup'

RESOLVED DUPLICATE of bug 1271047

Status

RESOLVED DUPLICATE of bug 1271047
2 years ago
4 months ago

People

(Reporter: dw-dev, Unassigned)

Tracking

46 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0
Build ID: 20160502172042

Steps to reproduce:

I executed the following code:

chrome.windows.create({ type: "popup", tabId: tabId, url: tabUrl,
                                    left: tile.left, top: tile.top, width: tile.width, height: tile.height },
function(newwin)
{
    .....
});

The 'left' and 'top' parameters are ignored.  The new popup window is always created slightly displaced from the existing window.

This is incompatible with Chrome, which positions the new popup window according to the 'left' and 'top' parameters if present, or otherwise slightly displaced from the existing window.



Actual results:

A new popup window is created, but the 'left' and 'top' parameters are ignored.


Expected results:

A new popup window should be created and positioned according to the 'left' and 'top' parameters.

Comment 1

2 years ago
dw-dev, as you're aware of the working of BMO, could you triage directly yourself your Web Extensions bug reports in Toolkit::Web Extensions, please.
Component: Untriaged → WebExtensions
Product: Firefox → Toolkit
(Reporter)

Comment 2

2 years ago
Yes, I am happy to do the triage myself.  I wasn't sure if I was allowed to do the triage myself, which is why I haven't done it in the past.

Unfortunately, I am finding rather a lot of bugs in WebExtensions at the moment!

Comment 3

2 years ago
If you're sure of the bug component, feel free to triage directly when creating the bug report. And it's not an issue if it appears to be wrong, someone will retriage after you if necessary. ;)

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1271047

Updated

4 months ago
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.