Closed Bug 1275266 Opened 4 years ago Closed 4 years ago

Rename imgLoader::Singleton and imgLoader::PBSingleton to something less misleading, and document them

Categories

(Core :: ImageLib, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla49
Tracking Status
firefox49 --- fixed

People

(Reporter: jwatt, Assigned: jwatt)

Details

Attachments

(1 file)

The method names Singleton and PBSingleton on imgLoader are misleading, especially at call sites where we only call Singleton(). (We can and do create multiple imgLoader instances.) The meaning of PBSingleton is also not obvious without digging into the code which isn't a very good way to figure out the meaning of an interface.
Attached patch patchSplinter Review
Attachment #8755859 - Flags: review?(tnikkel)
Attachment #8755859 - Flags: review?(tnikkel) → review+
https://hg.mozilla.org/mozilla-central/rev/2f3fc8f9ec43
https://hg.mozilla.org/mozilla-central/rev/b306ec471adf
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla49
You need to log in before you can comment on or make changes to this bug.