Closed Bug 1275270 Opened 3 years ago Closed 2 years ago

Missing logging in listener.js

Categories

(Testing :: Marionette, defect)

Version 3
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1357407

People

(Reporter: ato, Unassigned)

Details

Log statements in command implementations, possibly just those using the new dispatching technique, cause log statements not to get propagated to stdout.

The logger.debug("listener.js loaded") statement near the top of the file _does_ get printed and so does the logging statements I put into the dispatch() function, but only for the _first_ command.

It does not appear to be related to generator functions.

This obviously needs more investigation.
Interestingly we have similar issues with gecko logging for update tests on Windows only. See bug 1008135.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1384956
No, this is a dupe of bug 1357407.
Duplicate of bug: 1357407
You need to log in before you can comment on or make changes to this bug.