Closed Bug 1275335 Opened 4 years ago Closed 4 years ago

Download-Tooltip shows download duration for 56kBit/s

Categories

(SeaMonkey :: Website, defect)

Unspecified
All
defect
Not set
trivial

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: RainerBielefeldNG, Assigned: mctyson1795)

References

Details

(Whiteboard: [easyconfirm][good first bug])

Attachments

(7 files)

Attached image Screenshot with tooltip
Download via hyperlink in green download button area shows a tooltip "73.2 min @ 56k/min". I doubt that that information from analog modems age is interesting for users, should be removed.
Can be done all in one go with a fix for "Bug 1274632 - For SeaMonkey download use https://download-installer.cdn.mozilla.net/".
I want to solve this bug. I can do it.
I am new to the contribution, so can you please tell me where to find the source pages so that I can edit those files and submit a patch.
(In reply to prabhjot.nith from comment #2)
As a first step you should try to confirm the observations and leave a comment with your results. 
Source code: <https://hg.mozilla.org/SeaMonkey> "seamonkey-project-org"

Also see 
<https://developer.mozilla.org/en-US/docs/Mozilla/Developer_guide/How_to_Submit_a_Patch>
for a general description of the process. Once you are ready to submit a patch,
follow the steps there.
<https://developer.mozilla.org/en-US/docs/Mercurial/Using_Mercurial#How_can_I_generate_a_patch_for_somebody_else_to_check-in_for_me.3F>
and attach the patch here for review.
<https://developer.mozilla.org/en-US/Add-ons/AMO/Policy/Reviews> also might be interesting.

You only should scan through all those hints, otherwise it might be overwhelming.
Thanks @Rainer sir for your response.
I have downloaded the sources and tested the changes that are required to get rid of this tooltip online.
I can do the same for the html files that need changes.
hg is already installed and I am using Ubuntu 14.04 Linux.

hg pull -u is giving an error :: abort: repository default not found!

can I upload the edited files with a effected screenshot ?

any other way of submitting like in git we can submit file online .
@suraj
Can you help a little to get a review-ready patch here?
unnecessary title removed that leads to the tooltip.
There is required attachment file . I was getting mericural errors, so I uploaded in this way. Please review this, and I am trying to get with the hg.
BTW:
I find this string "56k/s" in 5 files:
 \seamonkey-project-org-d9e5f275e4ea\src\index.en.html
 \seamonkey-project-org-d9e5f275e4ea\src\releases\index.en.html
 \seamonkey-project-org-d9e5f275e4ea\src\start\index-test.en.html
 \seamonkey-project-org-d9e5f275e4ea\src\start\index.de.html
 \seamonkey-project-org-d9e5f275e4ea\src\start\index.en.html

I wonder whether index.de.html still is in use?
Yes sir these files also contain the text string but I thought the index.en.html file lying in the main folder is responsible for showing the content and other files doesn't affect it.
the other thing was that I was unable to upload all the 5 files in one go, so I asked review for one file.
Now uploading all the files that you mention in separate attachments.
Attached patch index.de.htmlSplinter Review
Attached patch index.en.htmlSplinter Review
Attached file index-test.en.html
Attached patch index.en.htmlSplinter Review
(In reply to prabhjot.nith from comment #4)
> hg pull -u is giving an error :: abort: repository default not found!

Please subscribe <news://news.mozilla.org/mozilla.dev.apps.seamonkey> and ask for assistance concerning this problem; alternative you can ask at <irc://irc.mozilla.org/seamonkey>
NEW due to <https://blog.seamonkey-project.org/2015/11/25/my-unconfirmed-bug-reports/>
Status: UNCONFIRMED → NEW
Ever confirmed: true
Prabhjot, if you need assistence to get this going just mail me.
Flags: needinfo?(prabhjot.nith)
No response. Just clearing needinfo flag.
Flags: needinfo?(prabhjot.nith)
Attachment #8821805 - Flags: feedback?(bugzilla)
Attachment #8821805 - Flags: feedback?(bugzilla) → feedback+
Now we also need to check-in this patch. Should I do it for you?
Assignee: nobody → mctyson1795
Status: NEW → ASSIGNED
(In reply to Frank Wein [:mcsmurf] from comment #18)
> Now we also need to check-in this patch. Should I do it for you?

Yes.
Pushed: https://hg.mozilla.org/SeaMonkey/seamonkey-project-org/rev/c45f051452267252f713f495de89237a8ef505e1

Thanks for the patch!
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Blocks: 1326010
Product: Websites → SeaMonkey
You need to log in before you can comment on or make changes to this bug.