Google keyboard is eating text backwards

VERIFIED FIXED in Firefox 47

Status

()

Firefox for Android
Keyboards and IME
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: kbrosnan, Assigned: jchen)

Tracking

Trunk
Firefox 49
All
Android
Points:
---

Firefox Tracking Flags

(firefox46- wontfix, firefox47+ verified, firefox48+ verified, firefox49+ verified, fennec47+)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
[Tracking Requested - why for this release]: Changed behavior by the Google keyboard app

1. Open https://pastebin.mozilla.org
2. Type several words
3. Move the cursor to the start or the middle of the text
4. Press and hold the delete key

expected: once the beginning of the text area is reached no more characters are removed

actual: once the beginning of the text area is reached the character to the right of the cursor is deleted
Flags: needinfo?(nchen)

Comment 1

2 years ago
Given that this is not a new recent regression, I think it is too late to uplift a fix in Fx47 for it.
status-firefox47: affected → wontfix
tracking-firefox47: ? → -
(Assignee)

Updated

2 years ago
Assignee: nobody → nchen
Status: NEW → ASSIGNED
Flags: needinfo?(nchen)
(Reporter)

Comment 2

2 years ago
[Tracking Requested - why for this release]: This is us being blindsided by Google Keyboard changes released last week. We need to consider a fix for at least the 47 cycle and I would be interested in a fix for the 46 cycle.
status-firefox47: wontfix → affected
tracking-firefox47: - → ?
Let's track this for 48/49 - given the new behavior sounds like it is more difficult to use the keyboard.
tracking-firefox48: ? → +
tracking-firefox49: ? → +
(Assignee)

Comment 4

2 years ago
Created attachment 8756522 [details] [diff] [review]
Add test for shift+backspace (v1)
Attachment #8756522 - Flags: review?(esawin)
(Assignee)

Comment 5

2 years ago
Created attachment 8756523 [details] [diff] [review]
Don't forward delete on shift+backspace (v1)

Shift+backspace causes a forward delete on some platforms, but not on
Android. The new Google keyboard is sending us shift+backspace, and we
need to handle it normally like a backspace.
Attachment #8756523 - Flags: review?(esawin)

Updated

2 years ago
Attachment #8756522 - Flags: review?(esawin) → review+

Updated

2 years ago
Attachment #8756523 - Flags: review?(esawin) → review+
tracking-fennec: ? → 47+

Comment 7

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/867bca2fa2a3
https://hg.mozilla.org/mozilla-central/rev/1ece2881d7b6
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox49: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 49
Too late for 46
status-firefox46: affected → wontfix
tracking-firefox46: ? → -
Jim, are you going to consider an uplift to 48 (and 47)? Thanks
Flags: needinfo?(nchen)

Comment 10

2 years ago
Tested using:
Device: HTC Desire 820 (Android 5.0.2)
Build: Firefox for Android Nightly - 49.0a1(2016-05-31)
status-firefox49: fixed → verified
(Assignee)

Comment 11

2 years ago
Comment on attachment 8756523 [details] [diff] [review]
Don't forward delete on shift+backspace (v1)

Request for this patch only (not the test)

Approval Request Comment
[Feature/regressing bug #]: N/A
[User impact if declined]: Wrong backspace behavior using new Google keyboard
[Describe test coverage new/current, TreeHerder]: Locally, m-c
[Risks and why]: No risk; patch is simple and specifically fixes the bug
[String/UUID change made/needed]: None
Flags: needinfo?(nchen)
Attachment #8756523 - Flags: approval-mozilla-beta?
Attachment #8756523 - Flags: approval-mozilla-aurora?
Comment on attachment 8756523 [details] [diff] [review]
Don't forward delete on shift+backspace (v1)

This seems like a recent regression (since 46) and seems like a common enough scenario in which characters that are not meant to be deleted will also be deleted and cause usability pain. Aurora48+, Beta47+
Attachment #8756523 - Flags: approval-mozilla-beta?
Attachment #8756523 - Flags: approval-mozilla-beta+
Attachment #8756523 - Flags: approval-mozilla-aurora?
Attachment #8756523 - Flags: approval-mozilla-aurora+

Updated

2 years ago
tracking-firefox47: ? → +

Comment 13

2 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-aurora/rev/3cc4a98864ad
status-firefox48: affected → fixed

Comment 14

2 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-beta/rev/cf6ec12bd620
status-firefox47: affected → fixed

Comment 15

2 years ago
Verified as fixed on the latest Beta build 47.0b10. This issue was tested on a Xiaomi mi i4 with Android 5.0.2, Xiaomi MI Pad2 with Android 5.1 and a Nexus 6P with Android N.
status-firefox47: fixed → verified
Verified as fixed using:
Device: One A2001 (Android 5.1.1)
Build: Firefox for Android Aurora 48.0a2 (2016-06-02)
Status: RESOLVED → VERIFIED
status-firefox48: fixed → verified
You need to log in before you can comment on or make changes to this bug.