Closed Bug 127539 Opened 18 years ago Closed 15 years ago

banking.diba.de - JavaScript can't access formular data

Categories

(Tech Evangelism Graveyard :: German, defect)

x86
All
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: dellwo, Unassigned)

References

()

Details

(Keywords: ecommerce)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7) Gecko/20011229
BuildID:    0.9.7

At https://banking.diba.de opens a popup window, where you can log on to your
online banking account. You have to fill out the formular and click on
"Anmelden"-Button. The Button is a <img> with a OnClick-JavaScript method. The
script seems to validate the values you filled into the form and then passes it
to another page. But when I click on the Image, nothing happens and JavaScript
console says: "document.formular has no properties" 

So I think the problem is in the JavaScript Engine of Mozilla, because the page
works fine with Netscape 4.7, IE 5.1 and opera.
I can also reproduce this with Mozilla running under Windows and Linux.



Reproducible: Always
Steps to Reproduce:
1.Go to https://banking.diba.de
2.In the popup window leave the formular blank or fill in some values
3.Click on "Anmelden" Button ==> Nothing happens

Actual Results:  Nothing :)

Expected Results:  When you have nothing filled in, the script tells you that
you have to fill out the formular. 
If your password etc is wrong it will tell you. But under Mozilla nothing happens.
If your password and account information ar right, you get redirected to  your
online banking interface.
This problem is evangelism.
"formular" is the id of a div (<div id="formular">), so to access it the right
code is document.getElementById("formular") instead of document.formular
Assignee: rogerl → nitot
Status: UNCONFIRMED → NEW
Component: JavaScript Engine → Europe: West
Ever confirmed: true
Product: Browser → Tech Evangelism
QA Contact: pschwartau → caillon
Version: other → unspecified
is this the only issue ? im having trouble reaching the site, but if is the only
problem, then we can mark the bug as [havefix] in the status whiteboard...
I don't have any problem to access the site, the popup window has some frames,
and the url of the main one is
https://banking.diba.de/DIBA?REQUEST_HANDLER=STARTUP&ZIEL=main

the script is coded all the same way, using document.element.property instead of
document.getElementByID().property, and also using .visibility instead of
.style.visibility

Propably it could work without too much trouble.
mmm, strange, I can reach it now :)
working on a fix, shouldnt be too hard.
Summary: JavaScript can't access formular data → banking.diba.de: JavaScript can't access formular data
When will there be a fix for this problem?
sorry didnt have time, and forgot :)

the files that need a fix :
https://banking.diba.de/DIBA?REQUEST_HANDLER=STARTUP&ZIEL=main
https://banking.diba.de//OnlineBanking/script/dhtml_lib.js

and probably
https://banking.diba.de//OnlineBanking/script/global.js too.
working on it, I will mark this bug as havefix when I've fixed the login part,
since this is the most important issue :)
*** Bug 137319 has been marked as a duplicate of this bug. ***
*** Bug 142724 has been marked as a duplicate of this bug. ***
*** Bug 159203 has been marked as a duplicate of this bug. ***
*** Bug 164882 has been marked as a duplicate of this bug. ***
Since there is no progress with this issue yet, I wanna ask where I have to look
in the mozilla source to develop a fix by myself.

Another question - is this issue a bug in mozilla or a bug in DIBA's javascript
code?
not mozilla related, its a bug on their javascript code (read my comment about
the files that need some work) - thats why its a Tech Evangelism bug.
I dont have time for this right now, so feel free to work on a fix. contact me
if you need any information.
Blocks: 124594
*** Bug 169150 has been marked as a duplicate of this bug. ***
*** Bug 171118 has been marked as a duplicate of this bug. ***
Yesterday I sent an email to DiBa using the contact formular on their homepage,
noting that their online banking does not currently work with Mozilla/Netscape
6.x/7.x and asking when/if this would be fixed. In it I also referred them to
this bug report. Today I received the following reponse (my translation):

"presently no changes or updates are planed for the access requirements [to
DiBa's  online banking]. We regret to not be able to give you a different answer."

Guess I won't open a new banking account with DiBa then...
Just entered a complaint about them at Vocatus.de. This is a site that
communicates customer complaints directly to companies.
*** Bug 189667 has been marked as a duplicate of this bug. ***
In https://banking.diba.de//OnlineBanking/script/dhtml_lib.js, I read things like:

function clipLayer(name, w, h) {
	if (is.ns4) {
	eval('document.'+name+'.clip.width = ' + w);
	eval('document.'+name+'.clip.height = ' + h);
	}
	if (is.ns6) {
	 eval('document.getElementById(name).clip.width="'+w+'"');
	 eval('document.getElementById(name).clip.height="'+h+'"');
	}
	if (is.ie) {
		eval(name).style.clip = "rect(0 " + eval(w) + " " + eval(h) + " 0)";
    }
}

Seems that they're on the right way?!
In JS Console, I now only see:

Error: formular is not defined
Source File: https://banking.diba.de/DIBA?REQUEST_HANDLER=STARTUP&ZIEL=main#
Line: 88


Error: event is not defined
Source File: https://banking.diba.de/DIBA?REQUEST_HANDLER=STARTUP&ZIEL=main#
Line: 80

Error: document.all has no properties
Source File: https://banking.diba.de/DIBA?REQUEST_HANDLER=STARTUP&ZIEL=main#
Line: 236
Jens:
no, they are not doing it the right way.
first they are detecting Netscape 5, and not gecko as they should.
also the function you are quoting is not correct ... a correct way would be :
if (document.getElementById)
  document.getElementById(name).style.clip = "rect(0 " + w + "px " + h + "px 0)";

anyway, https://banking.diba.de//OnlineBanking/script/dhtml_lib.js is quite easy
to fix, but there are other parts to fix. I dont have time for this myself right
now...
btw, is it Linux specific ? I dont have any other os nearby to check...

we should at least find a contact to tell them about the issue and ask if they
would apply a fix if we had one...
No, it is not Linux-specific. I have the same problem with Windows XP Home and
Mozilla 1.2.1.
OS: Linux → All
Answer to the question, when will it be possible to have access to diba online
banking with mozilla:

ein möglicher Termin könnte Sommer 2003 sein.
(possibly summer 2003)
CC -> self

I'm seeing the same problem - I just sent eMail to their support address. 

(Linux, Mozilla 1.4a)
I have received an answer to my support request today - unfortunately a negative
one. The text below is my own translation from German - for those of you who
read German, I attached the original message at the end of this comment.

[translated from German]
Dear Mr. Hamacher,

thanks for your eMail message.

Internet banking at DiBA is possible using Microsoft IE and Netscape Navigator.
[...]
Our login statistics show that 97% of the people visiting our homepage login
using IE or the Netscape browser. <Note: they really said 'the Netscape
browser', like they were not aware that there is a new 'Netscape browser' beyond
4.x!> This confirms that we have made the right decision offering internet
banking for those browser versions.

The technical effort to offer a solution or support for each browser in the
market would be very high. Like every other enterprise, we have to balance cost
and revenue. Only by doing this can we offer our attractive conditions.

We are glad to have received your suggestions for improvement. We will assess
future possibilites for implementing them. Please understand that at the present
 time, we can not give a definitive date.

[original answer in German]
Sehr geehrter Herr Hamacher,


vielen Dank für Ihre E-Mail.

Das Internetbanking der DiBa ist mit den Browsern Microsoft Internet Explorers
und Netscape Navigator möglich.
Weitere Informationen zu den Zugangsvoraussetzungen erhalten Sie über folgenden
Link: www.diba.de/ks/ibanking/zugangsvor/fs_zugangsvor.html

Unsere Log-in Statistik sagt aus, dass sich 97% aller Besucher unserer Homepage
über den Microsoft-Internetexplorer sowie über den Netscape-Browser einloggen.
Das gibt uns die Bestätigung, dass die Entscheidung das Internetbanking für
diese Browserversionen anzubieten, richtig ist.

Der technische Aufwand für jeden anderen am Markt befindlichen Browser eine
Lösung oder Support anzubieten, wäre sehr hoch. Wie bei allen Unternehmen der
Wirtschaft müssen auch bei uns Kosten und Erträge eine gewisse Balance haben.
Nur so ist es uns möglich, Ihnen diese vorteilhaften Konditionen anzubieten. 

Ihre Anregungen haben wir gerne entgegengenommen. 
Wir werden die Möglichkeit zur Umsetzung überprüfen und versuchen, sie
entsprechend zu berücksichtigen. 
Bitte haben Sie Verständnis dafür, wenn wir Ihnen heute noch keinen definitiven
Termin hierfür nennen können.




Mit freundlichen Grüßen

Sonja Keller
E-Mail Team

DiBa - Allgemeine Deutsche Direktbank AG
Theodor-Heuss-Allee 106
60486 Frankfurt am Main
*** Bug 199259 has been marked as a duplicate of this bug. ***
I received the very same email as in comment 24. I wrote them back that they it
is quite natural that they have 97% IE users if their site is not compatible;
that every large German bank I checked worked with Mozilla; that they just need
to comply to web standards; that they should use validator.w3.org; that the
Mozilla community might help; that this help wouldn't cost them anything.

I received this answer (translated):
We will check the possibilites for implementation and try to consider them
accordingly. Please understand that we cannot give you a definitive date today yet.

For the Germans:
Ihre Anregungen haben wir gerne entgegengenommen.
Wir werden die Möglichkeit zur Umsetzung überprüfen und versuchen, sie
entsprechend zu berücksichtigen.
Bitte haben Sie Verständnis dafür, wenn wir Ihnen heute noch keinen definitiven
Termin hierfür nennen können.
Mit freundlichen Grüßen
Sonja Keller
E-Mail Team
Re comment #26
Unfortunately, this seems to be another prefabricated form letter. Note that it
is absolutely identical to the last paragraph of the message I quoted in comment
#24 :-(

I also got back to them after receiving the message quoted in comment #24,
giving essentially the same arguments as those mentioned by Steffen in comment
#26. I received another prefabricated block of text informing me that my message
had been forwarded to some sort of 'complaint management department' - I haven't
heard from them since.

It seems that for the time being, there hasn't been any change of stance on
their end :-(

GRTX, -Chris
Summary: banking.diba.de: JavaScript can't access formular data → banking.diba.de - JavaScript can't access formular data
move...
Assignee: nitot → german
Component: Europe: West → German
QA Contact: z-caillon-obsolete2 → german
tell them you'll move to another bank, if they don't fix this, that might help
(else they are not worth to be their customer imho)
For me this works with Netscape 7.02 but not 7.1, I guess that is why they say
it works for Netscape. Why did it once work and now does not anymore? Did
Mozilla change in the way that it once worked fine with JS that is evangelism today?
*** Bug 213171 has been marked as a duplicate of this bug. ***
Why doesn't Modzilla treat this bug seriously ? 
Diba ist not a small bank !
I guess this bug is not taken seriously because either it is seen as their
fault, i.e. they simply write bad code that is not standard, thus this is
evangelism, or this bug does not have enough votes and/or CCs to take it seriously.
As I have pointed out before it is a bit weird that now being considered
evangelism this bug was working with NS 7.0x and I guess Mozilla 1.0x.

Though I also have to say that it is not very professional if diba officially
states in an email that it supports browsers till IE 5.02 and NS 4.76.
Armin: Tech Evangelism means : 
This is a error in the page itself and not Mozilla´and we can't fix it in Mozilla.
Let me repeat this, this WORKED in NS 7 and equivalent Mozillas. So it was
"fixed". Try it yourself and use NS 7.0x to submit the form.
to comment 35:
i just installed NS 7.0
Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.0.1) Gecko/20020823
Netscape/7.0

it is not working!
To s.burmeister, when it is working with 7.0 and 7.02 witch agent are you 
using?
Günter
I also received the letter in comment 24 and wrote back, let's see. If enough
people complain - who knows ?
Hi,

just complained to info@diba.de and received their standard reply.

This is just plain stupid to tell your customers that 97% of all 
people are using IE and old NS versions to access their website, 
if your online banking does not work with other browsers. 

If you are a DIBA customer please write an email to info@diba.de and
complain. Maybe if enough people complain something will happen.
Sonja Keller scheint der sympathie-erweckende Namen des Kellerautomaten zu sein,
der die Emails beantwortet. (Oder unterschreiben alle Diba-Hotmail-Mitarbeiter
mit diesem Namen, damit sie sich hinter dem gemeinsamen Pseudonym nicht
persönlich angreifbar machen?) 
*** Bug 215623 has been marked as a duplicate of this bug. ***
*** Bug 214483 has been marked as a duplicate of this bug. ***
*** Bug 216702 has been marked as a duplicate of this bug. ***
Keywords: ecommerce
Just for your information, DiBa seems to work with Konqueror (tested with
v.3.1.2)  - at least I can login correctly. It only works if Konqueror spoofs
the User Agent as Internet Explorer 5.1 :-(. If you use Konqueror as is, you get
a "page not found" error; definitely a very unprofessially made website.

Incidentially, DiBa not only does not officially support "exotic systems" such
as Linux (and Apple Macintosh), they do not even support Windows XP, because "it
was not on the market when our system was developed" (I guess that's why there
are standards for HTML etc.). See
http://www.diba.de/ks/ibanking/zugangsvor/cf_zugangsvor.html
(in German).

I would really like to know how the people who developed their web application
obtained their jobs... 
I wrote another email to DiBa on Saturday and today received a reply that does
give some room for hope for an improvement of the current state of their
internet banking application:

[english translation below]
"... Wir arbeiten der Zeit verstaerkt an einer Erweiterung der Versionen. Die
Wichtigkeit dieser Ergaenzung ist uns sehr wohl bewusst. Bitte haben Sie jedoch
Verstaendnis, wenn wir Ihnen heute noch keinen definitiven Termin hierfuer
nennen koennen. ..."

"... We are currently working on an extension of the versions [of internet
browsers supported]. We are well aware of the importance of this extension. But
please understand that we cannot give you a definite target date. ..."
false hope, some people got the same (by letter!) in 2001. 
*** Bug 180480 has been marked as a duplicate of this bug. ***
*** Bug 217302 has been marked as a duplicate of this bug. ***
Just wrote a protest mail threatening to withdraw my money ... I'll keep you
updated on the results.
I also complained and got the 2 standard responses ("97%", "working on it").
"Sonja Keller" sent me the following reply:

"Sehr geehrter ...,

vielen Dank für Ihre E-Mail.

In Ihrer E-Mail teilen Sie uns mit, dass unser Internetbanking nicht für die von
Ihnen genutzte Browserversion entwickelt ist. 

Wir arbeiten der Zeit verstärkt an einer Erweiterung der Versionen. Die
Wichtigkeit dieser Ergänzung ist uns sehr wohl bewusst. Bitte haben Sie jedoch
Verständnis, wenn wir Ihnen heute noch keinen definitiven Termin hierfür nennen
können.


Mit freundlichen Grüßen

Sonja Keller
E-Mail Team

DiBa - Allgemeine Deutsche Direktbank AG
Theodor-Heuss-Allee 106
60486 Frankfurt am Main

info@diba.de"

Basically the mail indicates they are working on something to support other /
newer browsers, but they refuse to announce any date for the changes becoming
effective.
By the way, this is what I wrote them. Sorry, no time to translate it in English:

"Sehr geehrte Damen und Herren,
 
mit Bedauern muß ich feststellen, daß die Banking-Seite (in meinem Fall die des
Extra-Kontos) nicht korrekt mit Browsern auf Mozilla-Basis arbeitet. Ich
verwende Mozilla Firebird 0.6 und kann mich nicht anmelden, da es zu
Javascript-Fehlern kommt. Diese liegen eindeutig an der Programmierung Ihrer
Seite und NICHT am verwendeten Browser. Ich habe mich eingehend über die
Problematik informiert und bin zu der Überzeugung gelangt, daß die DiBa
bestehende und gültige Standards der Javascript-Programmierung verletzt. 
 
Bitte schicken Sie mir nicht einen Ihrer im Internet zur Genüge kolportierten
Serienbriefe mit dem Hinweis, daß 97% aller Benutzer IE5 oder Netscape 4.x mit
Ihrer Seite benutzen. Bei einer Seite, die mit anderen Browsern nicht
funktioniert, ist das eine Selbstverständlichkeit und als Begründung dem Kunden
gegenüber eine Frechheit.
 
Ich bitte Sie, diese Mängel abzustellen bzw. mir einen Termin zu nennen, wann
das geschehen sein wird. Der Zwang zur Verwendung eines derart unsicheren
Browsers wie Microsoft IE5 oder des veralteten Netscape 4.7 ist für mich
ärgerlich und unverständlich. Sollten Sie zu Verbesserungen an Ihrer Seite nicht
bereit sein, werde ich überlegen, meine Ersparnisse (immerhin mehrere 10.000
Euro, wie Sie unter Konto-Nr. xxx sehen können) zu einer Bank zu transferieren,
die besseren Kundenservice bietet.
 
In Erwartung einer positiven Antwort verbleibe ich
 
Mit freundlichen Grüßen"
*** Bug 221102 has been marked as a duplicate of this bug. ***
Seems as if they finally made it.

wfm Mozilla 1.5 Linux
WFM finally !

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20031219
Firebird/0.7+ (Oxs G7 SSE optimized)
Yes, it's working now.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20031220
Firebird/0.7+
Works: Mozilla 1.4 Windows.
Yep, it works for me too.
Mozilla 1.5.1
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5.1) Gecko/20031120
4 WFM,
-> FIXED
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
It does NOT work with "Depot-Konten" (brokerage account)!
Only this message appears:
"... Anmeldung ist erfolgt, Depot wird initialisiert ...",
and nothing happens.
(it works only with "Extra-Konto" and "Direkt-Konto")

Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.4) Gecko/20030830
Confirmed: Does NOT work with Depot-Konto (not only that you can't access the
brokerage account, you can't access anything).

I have a brokerage account there since yesterday, today I tried to login:

When you log in, a message appears saying: "... Anmeldung ist erfolgt, Depot
wird initialisiert ..." (Login successful, brokerage account is being
initialised) and nothing else happened. 

When I click on Direkt-Konto -> Umsatzanzeige, a JavaScript windows appears
saying: "Die Geschäftsvorfälle stehen Ihnen erst nach der Anmeldung zur Verfügung."

Please  re-open!
*** Bug 233354 has been marked as a duplicate of this bug. ***
Reopening, since there are still some people who are having problems. See bug
233354, comment #59, comment #60.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
On 13th April they will start using a new system (got a ad letter from them
today). Maybe that'll change something?
Now it works:
Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.6) Gecko/20040123
Can anybody confirm this? A nightly build would also be good.
Yes, they activated their new brokerage today (or last night). 

WFM Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.6) Gecko/20040122 Debian/1.5-2
StumbleUpon/1.89
*** Bug 233997 has been marked as a duplicate of this bug. ***
Marking Bug Fixed Based on Comment #66 and Comment #68
Status: REOPENED → RESOLVED
Closed: 16 years ago15 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
Actually this bug is due to The problem called evangelism.
"formular" is the id of a div (<div id="formular">), so to access it the right
code is document.getElementById("formular") instead of document.formular
helper at http://www.carmechanicsimulator2015mod.com/
You need to log in before you can comment on or make changes to this bug.