setScriptTimeout doesn't work in Marionette

RESOLVED FIXED

Status

Testing
Marionette
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: matt, Unassigned)

Tracking

49 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.54 Safari/537.36

Steps to reproduce:

1. git clone https://github.com/gauntface/simple-push-demo.git
2. npm install
3. Set FF_BETA_PATH and FF_NIGHTLY_PATH in your PATH. For me this looks like the following in my zshrc:

    # Firefox Versions
    export FF_BETA_PATH="${HOME}/Projects/Tools/firefox-beta/firefox";
    export FF_NIGHTLY_PATH="${HOME}/Projects/Tools/firefox-nightly/firefox";

4. npm run test


Actual results:

All browsers should work with selenium-webdriver


Expected results:

Firefox nightly throws and error when calling:

    driver.manage().timeouts().setScriptTimeout(2000);

The error is:

    UnknownCommandError: POST /session/79f6042f-838d-4166-ba6f-b8ff9a26eb70/timeouts/async_script did not match a known command
Resolving as fixed as it is being fixed in https://github.com/SeleniumHQ/selenium/pull/2185
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Marionette is following the spec here and the client needs updating.
You need to log in before you can comment on or make changes to this bug.