'Edit' button is not immediately hidden when removing the last 3rd party search engine

RESOLVED FIXED

Status

()

Firefox for iOS
General
RESOLVED FIXED
2 years ago
a year ago

People

(Reporter: csuciu, Assigned: sleroux)

Tracking

({reproducible})

unspecified
Other
iOS
reproducible

Firefox Tracking Flags

(fxios5.0+, fxios-v5.0 verified, fxios-v6.0 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
master: 3c8f33c5
iPhone 6 Plus (9.3.2)

1. Add Youtube as 3rd party search engine
2. Go to Settings > Search, tap on 'Edit' and remove Youtube from the Quick-search Engines list
3. Check the 'Edit' button

Expected: The 'Edit' button should be hidden after removing the 3rd party search engine

Actual: The 'Edit' button is hidden only after exiting/re-entering the Search settings screen
(Reporter)

Comment 1

2 years ago
Also, the 'Edit' button is displayed when there is only one 3rd party search engine added and it is set as default search engine. Since removing the default search engine is not supported, the 'Edit' button should not be displayed

Updated

2 years ago
Keywords: reproducible
Rank: 3
tracking-fxios: ? → 5.0+
Assignee: nobody → sleroux
(Assignee)

Comment 2

2 years ago
Created attachment 8758753 [details] [review]
Link to Github pull-request: https://github.com/mozilla/firefox-ios/pull/1872
Attachment #8758753 - Flags: review?(fpatel)
(Assignee)

Updated

2 years ago
Status: NEW → ASSIGNED
Thanks for getting to this! Much appreciated.
I've reviewed it. Looks great!

Updated

2 years ago
Attachment #8758753 - Flags: review?(fpatel) → review+
(Assignee)

Comment 4

2 years ago
master f8b7729d0446214dfae32a67fd0615cf200336a4
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-fxios-v6.0: --- → fixed
Resolution: --- → FIXED
Whiteboard: [needsuplift]
(Assignee)

Comment 5

2 years ago
v5.x 8472b1d35314700aefa3536b6032886064e65369
status-fxios-v5.0: affected → fixed
Whiteboard: [needsuplift]
Verifying as fix on master 6ad4b686.
status-fxios-v5.0: fixed → verified
You need to log in before you can comment on or make changes to this bug.