iframe mouseover event is not firing after adding overflow property to body

RESOLVED DUPLICATE of bug 1265237

Status

()

Core
DOM: Events
RESOLVED DUPLICATE of bug 1265237
2 years ago
6 months ago

People

(Reporter: saravg4u, Unassigned)

Tracking

46 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Updated

2 years ago
Component: Untriaged → DOM: Events
Product: Firefox → Core
(Reporter)

Description

2 years ago
Created attachment 8756289 [details]
ff-hover-bug.html

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/50.0.2661.94 Safari/537.36

Steps to reproduce:

Have an iFrame with content inside a div, in my case I have an image loaded inside iframe and there are nested iFrames also. The HTML Structure will be <body><div><iframe>Image</iframe></div></body>. Add "mouseover/mouseenter" event listener to the div/iframe/body. On 'mouseover' try changing the overflow property of the 'BODY Element' to 'hidden' and set back to 'auto' on mouseleave. 

On the next time, when you hover on the div/iframe, mouseover is not getting fired.


Actual results:

Changing the overflow property of the body element is not firing the mouseover/mouseenter events from the next time


Expected results:

Whatever change in the css property all the events should get fired. It works in all other browsers like chrome/IE.

I have attached a sample page to test.
Olli probably knows what's up here.
Flags: needinfo?(bugs)
Whiteboard: btpp-followup-2016-07-05
I wasn't sure what the test case was supposed to do but bug 1265237 was fixed in the meantime and I think was related. Please re-open if that's not the case.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 months ago
Flags: needinfo?(bugs)
Resolution: --- → DUPLICATE
Whiteboard: btpp-followup-2016-07-05
Duplicate of bug: 1265237
You need to log in before you can comment on or make changes to this bug.