[meta] Add a site permission management interface

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: mconley, Assigned: prathiksha)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

We had an about:permissions for a while, but it wasn't designed very well, and eventually got removed (see https://mail.mozilla.org/pipermail/firefox-dev/2015-November/003509.html).

Control Center allows the user to modify site permissions on a per-site basis, but a global permissions manager (like what the original about:permissions likely intended to be) still seems desirable.

So this is the meta bug to track a better replacement for the old about:permissions.

Comment 1

3 years ago
I think ideally this would be part of about:preferences. There's not much of a distinction between preferences and permissions to the average user and we already surface many things in preferences around cookies and offline data (though quite poorly).
Yeah, the idea is to be part of preferences and to be the inverse of what about:permissions was so you choose a permission type then see the origins. This is what almost all the prior art on mobile and desktop OSs use.  I don't even know that this needs to be a meta bug since it would be fairly easy to implement the basic per-site UI using SitePermissions.jsm.

The nice thing about having the top of the hierarchy be a permission type is that it allows for global options to also appear for a permission type.
Component: Device Permissions → Preferences
Depends on: 1161553
Summary: [meta] Add a better about:permissions → [meta] Add a site permission management interface
Assigning myself since this is the Outreachy project I'd like to mentor soon.

Design spec is here: https://mozilla.invisionapp.com/share/5RA0R4HAE#/screens/220667161
Assignee: nobody → jhofmann
Status: NEW → ASSIGNED
Assignee: jhofmann → prathikshaprasadsuman
Latest design specs:

https://mozilla.invisionapp.com/share/4ZB63CHD9#/screens/227453094

We agreed to change the scope of this to not include global disable as an MVP (because of implications on users accidentally breaking their websites), though a lot of different sources are interested in some kind of global permission toggle, so we're currently figuring out a way to make that happen.
Depends on: 1361684
Duplicate of this bug: 1314281
(Assignee)

Updated

2 years ago
Depends on: 1372578
(Assignee)

Updated

2 years ago
Depends on: 1373206
No longer depends on: 1313939
Depends on: 1385222
Depends on: 1385221
Depends on: 1381401
All dependent bugs are resolved, so let's close this!

There's still the issue of global permission settings, we're planning to add one for notifications in bug 1368744, but that wasn't in the MVP scope for this project, so I think we can safely declare this bug done.
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.