The height of the private browsing indicator changes a lot if you show/hide the window titlebar

RESOLVED INVALID

Status

()

Firefox
Theme
RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: mstange, Unassigned)

Tracking

Trunk
All
Mac OS X
Points:
---

Firefox Tracking Flags

(firefox49 affected)

Details

(Reporter)

Description

2 years ago
STR:
 1. Open a new private browsing window.
 2. In the hamburger panel, click Customize.
 3. In the bottom left corner of the customization tab, click on the "Title Bar" button a few times and watch the purple private browsing indicator in the top right corner of the window.

Expected results:
The indicator shouldn't change much.

Actual results:
The indicator is much smaller when the title bar is visible.

Comment 1

2 years ago
I think this is by design, but maybe Stephen has ideas about how to make this better. I'm not too worried about the constantly switching it around case, but perhaps we think we should get rid of one and use the other, or something?
Flags: needinfo?(shorlander)
My understanding was that it had to fit within the height of the titlebar when it was turned on. But you would get some weird alignment issues if it stayed the same size in both configurations.

I tried to keep it aligned with the bottom of the window controls: http://cl.ly/393r3x3T390D
Flags: needinfo?(shorlander)
(Reporter)

Comment 3

2 years ago
Oh, I see, thanks. Good to know that it's working as intended!
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.