All users were logged out of Bugzilla on October 13th, 2018

Garbled text within the flash element with HWA disabled

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: over68, Assigned: sotaro)

Tracking

({regression})

49 Branch
x86_64
Windows 7
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gfx-noted])

Attachments

(3 attachments, 3 obsolete attachments)

(Reporter)

Description

2 years ago
Steps to reproduce:

1. Disable hardware acceleration.
2. Restart Firefox.
3. Go to https://dl.dropboxusercontent.com/u/95157096/85f61cf7/7opdfz1nz3.html.
4. Go to the video tape.


Actual results:

Garbled text within the flash element with HWA disabled.

Screenshot https://dl.dropboxusercontent.com/u/95157096/85f61cf7/gekrznfo3e.png
(Reporter)

Comment 2

2 years ago
[Tracking Requested - why for this release]:

[Tracking Requested - why for this release]:

Regression range:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=d1ae745b7e3fcb2dbeea4814fa4f907160b1d0e9&tochange=0662b0935257f604567b816af81c369674786190

Regressed by: bug 1254897
Blocks: 1254897
tracking-firefox48: --- → ?
tracking-firefox49: --- → ?
Flags: needinfo?(sotaro.ikeda.g)
Keywords: regression
(Assignee)

Comment 3

2 years ago
I tried to reproduce the problem with latest nightly on my 3 win pcs. But failed to reproduce the problem. It seems to related flash plugin invalidation problem.
(Assignee)

Comment 4

2 years ago
blinky, can you reproduce the problem on latest nightly and latest flash plugin? Did you enabled multi-process?
Flags: needinfo?(sotaro.ikeda.g) → needinfo?(over68)
(Assignee)

Comment 5

2 years ago
I checked how two plugins work. The plugins are different types.
 - Plugin in comment 0: windowless plugin
 - Plugin in comment 1: windowed plugin

 https://developer.mozilla.org/en-US/docs/Plugins/Guide/Plug-in_Basics#Windowed_and_Windowless_Plug-ins
(Assignee)

Comment 6

2 years ago
(In reply to Sotaro Ikeda [:sotaro] from comment #5)
> I checked how two plugins work. The plugins are different types.
>  - Plugin in comment 0: windowless plugin
      It created ImageLayer for composition

>  - Plugin in comment 1: windowed plugin
     + non-multi process: It did not create layer.
         The plugin rendered to plugin's window and it is rendered to screen.
         compositor does not handle its rendering.
     + multi-process: ImageLayer is created for scroll handling.
      

> 
>  https://developer.mozilla.org/en-US/docs/Plugins/Guide/Plug-
> in_Basics#Windowed_and_Windowless_Plug-ins
(Assignee)

Comment 7

2 years ago
(In reply to Sotaro Ikeda [:sotaro] from comment #6)
> >  - Plugin in comment 1: windowed plugin
>      + non-multi process: It did not create layer.
>          The plugin rendered to plugin's window and it is rendered to screen.
>          compositor does not handle its rendering.
>      + multi-process: ImageLayer is created for scroll handling.

Correction:
   ImageLayer is not created also on multi-process cases.
(Reporter)

Comment 8

2 years ago
(In reply to Sotaro Ikeda [:sotaro] from comment #4)
> blinky, can you reproduce the problem on latest nightly and latest flash
> plugin? Did you enabled multi-process?

I can reproduce the problem with the latest nightly build, and with latest Flash Player beta 22.0.0.168.

With hardware acceleration disabled. See https://dl.dropboxusercontent.com/u/95157096/85f61cf7/f8qy73plfe.png


Mozilla/5.0 (Windows NT 6.1; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0
https://hg.mozilla.org/mozilla-central/rev/8d0aadfe7da782d415363880008b4ca027686137
(Reporter)

Updated

2 years ago
Flags: needinfo?(over68)
(Reporter)

Comment 9

2 years ago
I can also reproduce with and without multi-process.
Whiteboard: [gfx-noted]
(Assignee)

Comment 10

2 years ago
(In reply to Sotaro Ikeda [:sotaro] from comment #6)
> (In reply to Sotaro Ikeda [:sotaro] from comment #5)
> > I checked how two plugins work. The plugins are different types.
> >  - Plugin in comment 0: windowless plugin
>       It created ImageLayer for composition

Contents of the ImageLayer were opaque. From it, the problem seems not related to layer invalidation.
(Assignee)

Comment 11

2 years ago
:mattwoodrow, do you have ideas about what could be a possible cause?
Flags: needinfo?(matt.woodrow)
(Assignee)

Comment 12

2 years ago
(In reply to blinky from comment #8)
> (In reply to Sotaro Ikeda [:sotaro] from comment #4)
> > blinky, can you reproduce the problem on latest nightly and latest flash
> > plugin? Did you enabled multi-process?
> 
> I can reproduce the problem with the latest nightly build, and with latest
> Flash Player beta 22.0.0.168.

Thanks for the information! I also tried with latest Flash Player beta 22.0.0.168, and confirmed the problem.
(Assignee)

Updated

2 years ago
Assignee: nobody → sotaro.ikeda.g
(Assignee)

Comment 13

2 years ago
With mozregression, I got bug 1259541.

Disabling bug 1254897 or bug 1259541 addressed the problem of comment 0. But both did not address the problem of Comment 1 on current master.
(Assignee)

Comment 14

2 years ago
(In reply to Sotaro Ikeda [:sotaro] from comment #7)
> (In reply to Sotaro Ikeda [:sotaro] from comment #6)
> > >  - Plugin in comment 1: windowed plugin
> >      + non-multi process: It did not create layer.
> >          The plugin rendered to plugin's window and it is rendered to screen.
> >          compositor does not handle its rendering.
> >      + multi-process: ImageLayer is created for scroll handling.
> 
> Correction:
>    ImageLayer is not created also on multi-process cases.

With latest Flash Player beta 22.0.0.168, ImageLayer was always created also for comment 1 case.
(Assignee)

Updated

2 years ago
See Also: → bug 1276020
(Assignee)

Updated

2 years ago
Flags: needinfo?(matt.woodrow)
(Assignee)

Updated

2 years ago
See Also: → bug 1217665
(Assignee)

Comment 15

2 years ago
When plugin async drawing is disabled, the both problems did not happen.
 - dom.ipc.plugins.asyncdrawing.enabled:true
(Assignee)

Comment 16

2 years ago
(In reply to Sotaro Ikeda [:sotaro] from comment #10)
> (In reply to Sotaro Ikeda [:sotaro] from comment #6)
> > (In reply to Sotaro Ikeda [:sotaro] from comment #5)
> > > I checked how two plugins work. The plugins are different types.
> > >  - Plugin in comment 0: windowless plugin
> >       It created ImageLayer for composition
> 
> Contents of the ImageLayer were opaque. From it, the problem seems not
> related to layer invalidation.

With latest Flash Player beta 22.0.0.168, ImageLayer's content changed from B8G8R8X8 to B8G8R8A8.
(Assignee)

Comment 17

2 years ago
The plugin of comment 1 also caused the problem when hwa enabled and multi-proccess off. From it, comment 0 and comment 1 seem different problem.
(Assignee)

Comment 18

2 years ago
Created attachment 8757346 [details] [diff] [review]
temporary patch - Dump plugin rendering to stderr

Used to dump plugin rendering.
(Assignee)

Comment 19

2 years ago
Created attachment 8757347 [details]
plugin rendering image of comment 2

Comment 1 plugin's rendering was already garbled by the plugin. Used attachment 8757346 [details] [diff] [review] to get the image.
(Assignee)

Comment 20

2 years ago
From comment 19, the bug focus to the problem of comment 0, since comment 1 is plugins bug.
(Assignee)

Comment 21

2 years ago
When I build master firefox on my pc, I saw the rendering problem also with hwa enabled and with multi-process.  By using attachment 8757346 [details] [diff] [review], I checked the flush plugin output, like comment 19, the plugin output already had the problem. In this case, hwa enabled and without multi-process, did not cause the problem.
(Assignee)

Updated

2 years ago
Attachment #8757347 - Attachment description: plugin rendering image → plugin rendering image of comment 2
(Assignee)

Comment 22

2 years ago
Created attachment 8757558 [details]
plugin rendering image of comment 21
(Assignee)

Updated

2 years ago
Attachment #8757558 - Attachment is obsolete: true
(Assignee)

Comment 23

2 years ago
Created attachment 8757560 [details]
plugin rendering image of comment 21
(Assignee)

Comment 24

2 years ago
From comment 21, I am going to focus to he problem of comment 0 without multi-process.
(Assignee)

Comment 25

2 years ago
The bus's situation become a bit complex now. I am going to split the comment 24 to different bug.
(Assignee)

Updated

2 years ago
Blocks: 1276403
(Assignee)

Updated

2 years ago
No longer blocks: 1276403
Depends on: 1276403
(Reporter)

Updated

2 years ago
tracking-firefox48: ? → ---
tracking-firefox49: ? → ---
(Assignee)

Comment 27

2 years ago
Created attachment 8759641 [details] [diff] [review]
patch - Fix nsPluginFrame::IsOpaque()
(Assignee)

Updated

2 years ago
Attachment #8759641 - Attachment is patch: true
Attachment #8759641 - Attachment mime type: text/x-patch → text/plain
(Assignee)

Updated

2 years ago
Attachment #8759641 - Attachment is obsolete: true
(Assignee)

Updated

2 years ago
Depends on: 1276020
See Also: bug 1276020
(Assignee)

Comment 28

2 years ago
(In reply to blinky from comment #26)
> This also happens in
> https://dl.dropboxusercontent.com/u/95157096/85f61cf7/ea6zbcyy1i.swf.
> 
> Screenshot
> https://dl.dropboxusercontent.com/u/95157096/85f61cf7/2kstrxxl4k.png

Since bug 1276020 and bug 1276403 fix, the above problem seems to be addressed.
(Assignee)

Comment 29

2 years ago
From Comment 19 and Comment 23, a remaining problem seems to exist in latest Flash Player beta 22.0.0.168.
(Assignee)

Comment 30

2 years ago
Created attachment 8774675 [details] [diff] [review]
wip patch
(Assignee)

Updated

2 years ago
Attachment #8774675 - Attachment is obsolete: true
(Assignee)

Comment 31

2 years ago
(In reply to Sotaro Ikeda [:sotaro] from comment #29)
> From Comment 19 and Comment 23, a remaining problem seems to exist in latest
> Flash Player beta 22.0.0.168.

The problem was addressed with Flash Player beta 23.0.0.126 on my pc.
(Assignee)

Comment 32

2 years ago
blinky, can you check if the problem is addressed?
Flags: needinfo?(over68)
(Reporter)

Comment 33

2 years ago
I can not reproduce this bug with Flash Player beta 23.0.0.126.
Flags: needinfo?(over68)
(Reporter)

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.