Closed Bug 12758 Opened 20 years ago Closed 20 years ago

CRASH: changing 'float' on :hover

Categories

(Core :: Layout, defect, P3, critical)

x86
Other
defect

Tracking

()

VERIFIED DUPLICATE of bug 10007

People

(Reporter: allen.sam, Assigned: troy)

Details

(Whiteboard: [testcase])

Attachments

(1 file)

Changing an element's 'float' value to 'left' or 'right' on :hover causes a
crash on divs whose float values are defaulted/set to 'none' (when :hover is not
triggered).
Whiteboard: [testcase]
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
Same basic problem as 10007. The style context is changing out from under the
frame and then when we go to delete the original frame we think it's floated
(but it's not) and so we hit an assert in the block frame code

*** This bug has been marked as a duplicate of 10007 ***
Status: RESOLVED → VERIFIED
verified dup.
You need to log in before you can comment on or make changes to this bug.