Galleries on repubblica.it are much faster in Chrome than Firefox

RESOLVED FIXED

Status

()

P3
normal
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: marco, Unassigned)

Tracking

({perf})

47 Branch
Unspecified
Android
Points:
---

Firefox Tracking Flags

(firefox47 wontfix, firefox48 wontfix, firefox49 wontfix, firefox50 wontfix, firefox51 fixed, firefox52 unaffected)

Details

(URL)

(Reporter)

Description

3 years ago
Moving between the different items (both by panning and by clicking on the arrows) is very slow in Firefox.
For me the gallery doesn't even load in Chrome. It switches into fullscreen mode with a black background and the white "X" in the top-right corner but no images actually appear.
(Reporter)

Comment 2

3 years ago
Interesting, it works for me in Chrome 44 (I haven't tried with a more recent version).
I have Chrome 50.0.2661.89 32-bit, running on a Nexus 4 with CM 13 (~Android 6.0.1)
(Reporter)

Comment 4

2 years ago
It works in Chrome 51 for me.

Can you test again? Try opening the gallery with the button at the center of the image (the one which reads "SFOGLIA LA GALLERIA").
Flags: needinfo?(bugmail)
Yeah it works in chrome now, and I agree it is much smoother than in FF.
status-firefox47: --- → wontfix
status-firefox48: --- → wontfix
status-firefox49: --- → wontfix
status-firefox50: --- → affected
Flags: needinfo?(bugmail)
Keywords: perf
OS: Unspecified → Android
Priority: -- → P3
This appears to be fixed in the latest Nightly, it is much smoother. Although hitting the X to get out of the gallery mode didn't seem to work. On 2016-09-19 50.0a2 it was still janky and the X worked, so this was fixed/regressed recently. I'll bisect.
Fix range: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=ea8a13e335c90ffa477ae7aaf0c0a3774985bb9f&tochange=2bb5563041e5f523d7820a27f0560a7cc66d2a61

This was fixed by the switch to skia in bug 725119. That's likely not going to be uplifted to 50, so marking 50 as wontfix.

I'll clone this bug and do another bisection to find out when the X broke, since that seems to have a different range.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox50: affected → wontfix
status-firefox51: --- → fixed
status-firefox52: --- → unaffected
Depends on: 725119
Resolution: --- → FIXED
(Reporter)

Comment 8

2 years ago
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #7)
> I'll clone this bug and do another bisection to find out when the X broke,
> since that seems to have a different range.

Could you CC me on the bug that you will open for the 'X'? Thanks!
Actually I'm not sure about the X thing anymore, I can't seem to reproduce it consistently. It seems like sometimes the page pops up another dialog underneath the gallery - seems like a "you have to create an account" kind of dialog but I don't know Italian so I don't know for sure. And when that happens, the X stops working. However the dialog itself seems sporadic so I don't know if I can pin this down.
(Reporter)

Comment 10

2 years ago
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #9)
> Actually I'm not sure about the X thing anymore, I can't seem to reproduce
> it consistently. It seems like sometimes the page pops up another dialog
> underneath the gallery - seems like a "you have to create an account" kind
> of dialog but I don't know Italian so I don't know for sure. And when that
> happens, the X stops working. However the dialog itself seems sporadic so I
> don't know if I can pin this down.

I was able to reproduce the bug, but unconsistently just like you.
I haven't seen a dialog, if you can share a screenshot I could translate it for you.
You need to log in before you can comment on or make changes to this bug.