Closed Bug 1276182 Opened 4 years ago Closed 4 years ago

Loop functional tests failing due to "Timed out after 10.1 seconds with message: Timeout out waiting for paused to be false"

Categories

(Hello (Loop) :: Client, defect, P1)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: standard8, Assigned: standard8)

References

Details

(Keywords: regression, Whiteboard: [blocked on marionette release])

Attachments

(1 file)

On the functional tests we're getting:

TEST-UNEXPECTED-ERROR | test_1_browser_call.py Test1BrowserCall.test_1_browser_call | TimeoutException: TimeoutException: Timed out after 10.1 seconds with message: Timeout out waiting for paused to be false


Traceback (most recent call last):
  File "/home/mozilla/jenkins/workspace/hello-e2e-marionette/loop-standalone/built/.venv/local/lib/python2.7/site-packages/marionette/marionette_test.py", line 351, in run
    testMethod()
  File "/home/mozilla/jenkins/workspace/hello-e2e-marionette/loop-standalone/test/functional/test_1_browser_call.py", line 228, in test_1_browser_call
    self.standalone_check_remote_video()
  File "/home/mozilla/jenkins/workspace/hello-e2e-marionette/loop-standalone/test/functional/test_1_browser_call.py", line 53, in standalone_check_remote_video
    self.check_video(".remote-video")
  File "/home/mozilla/jenkins/workspace/hello-e2e-marionette/loop-standalone/test/functional/loopTestDriver.py", line 131, in check_video
    self.wait_for_element_attribute_to_be_false(video, "paused")
  File "/home/mozilla/jenkins/workspace/hello-e2e-marionette/loop-standalone/test/functional/loopTestDriver.py", line 48, in wait_for_element_attribute_to_be_false
    message="Timeout out waiting for " + attribute + " to be false")
  File "/home/mozilla/jenkins/workspace/hello-e2e-marionette/loop-standalone/built/.venv/local/lib/python2.7/site-packages/marionette_driver/wait.py", line 143, in until
    cause=last_exc)
TEST-INFO took 66206ms

This is caused by bug 1272653 and requires a code change plus a new release of marionette for us to be able to use it (bug 1275843)
Attachment #8758337 - Flags: review?(edilee)
Attachment #8758337 - Flags: review?(dmose)
Attachment #8758337 - Flags: review?(dcritchley)
Attachment #8758337 - Flags: review?(edilee)
Attachment #8758337 - Flags: review?(dcritchley)
Comment on attachment 8758337 [details] [review]
[loop] Standard8:bug-1276182-functional-fixes > mozilla:master

r=dmose with comments addressed as appropriate
Attachment #8758337 - Flags: review?(dmose) → review+
Assignee: nobody → standard8
All fixed and the tests on the server are passing again :-)

https://github.com/mozilla/loop/commit/17e3cbd7760fb090a9deadf04977b6a27f3187e6
Status: NEW → RESOLVED
Closed: 4 years ago
Rank: 5
Resolution: --- → FIXED
Blocks: 1281619
You need to log in before you can comment on or make changes to this bug.