If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Status

()

Firefox
Untriaged
--
major
RESOLVED INVALID
a year ago
a year ago

People

(Reporter: Sander Van de Moortel, Unassigned)

Tracking

({perf})

46 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:46.0) Gecko/20100101 Firefox/46.0
Build ID: 20160502172042

Steps to reproduce:

It seems to randomly occur, but I am mostly working in Wordpress admin panels and developing my own websites which use jQuery.

With a fresh start of Firefox, the freezing isn't there. But after a while it comes back. Closing tabs does not help.


Actual results:

Firefox works normally, but every x seconds, the UI will hang for a second, causing interruptions in scrolling, in text typing, in right click menus, .. in short: the entire UI hangs for a second.


Expected results:

UI should run smoothly, bit like butter
Sander, to narrow down the problem, could you please try the following?

1) Test in a clean profile https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
2) Test in Safe Mode https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode
3) Disable hardware acceleration https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems#w_turn-off-hardware-acceleration
4) Try to get a stack trace from hung Firefox on Windows
https://developer.mozilla.org/en-US/docs/How_to_Report_a_Hung_Firefox

Please post back the results.
(Reporter)

Comment 2

a year ago
Quite strangely, while having suffered from it for the better part of 6 months, I haven't experienced this issue since I did a few things. First was to disable hardware acceleration as I was getting black artefacts. A second was to scale down my Win10 UI scaling from 150% (recommended) to 125%. Now I don't have time to test all various configurations, but if the bug shows up again later despite these new conditions, I will post here.
Based on the previous comment I'm setting this as Worksforme. 

Sanger, please don't hesitate to reopen it if the issue is back and reproducible.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

a year ago
It is back and -for me- reproducible. It always happens when having (several tabs with) Wordpress' Admin page open. After a bit of changing settings and content, the FF ui will start to lag. Closing these tabs will not help: the UI continues to lag and stutter until the browser is restarted.
(Reporter)

Updated

a year ago
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Comment 5

a year ago
Also goes for having the Squarespace editor open. After a while it will start freezing intermittently
Sander, since the issue is back and reproducible, the information required in Comment 1 is still valuable and necessary if we want to track down the cause of this issue. 

Could you please test the other configurations and post here the results?
Flags: needinfo?(sander.vandemoortel)
(In reply to Simona B [:simonab](PTO) from comment #6)
> Sander, since the issue is back and reproducible, the information required
> in Comment 1 is still valuable and necessary if we want to track down the
> cause of this issue. 
> 
> Could you please test the other configurations and post here the results?
Keywords: perf
Whiteboard: [closeme 2016-08-11]
Sander, are you still experiencing this issue? Any updates? (Please see Comment 6)
(Reporter)

Comment 9

a year ago
Unfortunately yes, heavily so. Seems to have something to do with a JavaScript running on FB.

Firefox will even show a windows title bar (even though there normally isn't one in FF anymore) during the longer of these freezes.

However, I'm too busy to install and run all kinds of logging software at the moment... :/

Comment 10

a year ago
I am experiencing lots of short hitches in Nightly (51.0a1 (2016-08-16)). I've tried a fresh profile as well as safe mode and disabling hw accel, no luck there. Running under Windows 10 Pro / 10586. I can go into about:memory and run garbage collection which resolves the issue for a short time, but some pages (heavy jquery usage) will trigger the issue again.

Updated

a year ago
Flags: needinfo?(sander.vandemoortel)
Whiteboard: [closeme 2016-08-11]
(Reporter)

Comment 11

a year ago
Ok this is starting to drive me insane, yet I don't quite want to give up on Firefox yet. What exactly do I need to do to report this kind of behaviour? Will using "analyse" on the Gecko Profiler work?

PS I'm using a Dell XPS 9350 with Skylake processor. It kind of feels like it's not managing the processor properly, so maybe this info helps?

PPS When the connection isn't very stable, I also get Facebook rendering my entire browser unresponsive for several seconds at a time. Sometimes it will ask me to stop executing a javascript, sometimes it will just resume. But most of all it makes my browsing experience extremely unpleasant. To the point where I've started using Edge by the side. Can you imagine how desperate I am?
(Reporter)

Updated

a year ago
Severity: normal → major
(In reply to Sander Van de Moortel from comment #11)
> Ok this is starting to drive me insane, yet I don't quite want to give up on
> Firefox yet. What exactly do I need to do to report this kind of behaviour?
> Will using "analyse" on the Gecko Profiler work?

https://developer.mozilla.org/en-US/docs/Mozilla/Performance/Reporting_a_Performance_Problem
(Reporter)

Comment 13

a year ago
OK here's a log from when Facebook rendered the entire browser unresponsive with a script. I think that's what it is, because I have no idea of how to use the profiler.

https://cleopatra.io/#report=235ca8a5ffd5f6a53b6976a75442482bc3f606fd


This isn't exactly what I meant by short UI freezes, as these essentially are pretty long (several seconds). But they may be related/similar?

Comment 14

a year ago
I'm having UI Freezes on Windows 10 as well sometimes apparentely random but often when Laptop was in standby/energy saving/hibernate.

Comment 15

a year ago
As of a few days ago, Nightly no longer shows symptoms for me, so my issue is resolved. There may be other problems with heavy sites still, but the intermittent hitching regardless of windows open is resolved.
Olli, could you please take a look on the Cleopatra profile from comment 13? Is there anything useful? Should Sander try to catch a new one?
Flags: needinfo?(bugs)
Sander, tons of time is spent in and under "Perapera Chinese". That seems to be some addon.
It seems to run some heavy javascript.
Could you try to disable it?
Flags: needinfo?(bugs)
(In reply to Olli Pettay [:smaug] from comment #17)
> Sander, tons of time is spent in and under "Perapera Chinese". That seems to
> be some addon.
Indeed https://addons.mozilla.org/en-US/firefox/addon/perapera-kun-chinese-popup-tra/
Something wrong with it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year agoa year ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.