[es-CL] Search engine setup for Firefox Mobile for Spanish from Chile

RESOLVED DUPLICATE of bug 1255595

Status

RESOLVED DUPLICATE of bug 1255595
3 years ago
3 years ago

People

(Reporter: delphine, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

We want to ship Firefox Mobile with a good list of search engines for Spanish from Chile. 

We're going to work towards this in three phases. First, the localization team and the l10n drivers will look at the market for the language and come up with a good set of search providers. Vedran and team, we'll need your input on this, the guidelines for making recommendations are on <https://wiki.mozilla.org/L10n:Mobile/Productization>. 

For en-US, we currently use this set, to which we can fall back in the case of lacking localized alternatives:

> Google, Yahoo, Bing, Amazon, Twitter, Wikipedia

We may also want to go with just a subset of the en-US engines, if that's more appropriate for the local market.

Once we decide to use a particular search engine (and we test it on a mobile device), l10n drivers will contact the owner and ask for permission, and for specifics like proper search flags. We'll likely need your help to at least get the contact information.

For search engines that we already ship with on desktop and that you would like to include in mobile as well, the permission is not needed.  Consider using a mobile version of the engine if one is available. For Android we'll want a specific 96x96px image, with colored background and rounder corners (6px radius).

Once we have a specification on what the search engines for Guaraní should look like, Delphine and the localization team will work on the implementation. Delphine will create and attach patches for the desired changes and get them reviewed. After a successful review, Delphine will land them. Vedran, if you're interested, you could create the patches, too. You'd ask Delphine for review on those before landing. 

Please don't commit any modifications in browser/searchplugins to the hg repository without a patch reviewed by flod, Axel or someone else appointed by the l10n drivers. The data here is sensitive to users and our search partners, thus the extra care here.

The es-CL team and Delphine will be driving this bug to completion.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1255595
thanks Richard, hadn't seen that bug :/
Blocks: 1255594
No longer blocks: 1274869
You need to log in before you can comment on or make changes to this bug.