getUserMedia() : When called several times in a row only the last call resolves

RESOLVED DUPLICATE of bug 861716

Status

()

Core
WebRTC: Audio/Video
P2
normal
Rank:
25
RESOLVED DUPLICATE of bug 861716
a year ago
a year ago

People

(Reporter: Olivier Audard, Unassigned)

Tracking

48 Branch
x86_64
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160527004031

Steps to reproduce:

When calling navigator.mediaDevices.getUserMedia() 2 times in a row, only the last call's Promise resolves.

Here is a reduced test case : https://jsbin.com/japibi/edit?js,console
Just click the "run" button in the "Console" section and agree to share your audio stream.


Actual results:

Actual console output :
"Requesting userMedia #1"
"Requesting userMedia #2"
"Got stream #2"
"#2 has resolved"


Expected results:

Expected console output : 
"Requesting userMedia #1"
"Requesting userMedia #2"
"Got stream #1"
"#1 has resolved"
"Got stream #2"
"#2 has resolved"
Component: Audio/Video → WebRTC
OS: Unspecified → Mac OS X
Hardware: Unspecified → x86_64
Status: UNCONFIRMED → NEW
Ever confirmed: true
Rank: 25
Priority: -- → P2
Component: WebRTC → WebRTC: Audio/Video
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 861716
You need to log in before you can comment on or make changes to this bug.