"Only users in the selected group..." message is confusing

RESOLVED DUPLICATE of bug 143045

Status

()

Bugzilla
User Interface
P2
enhancement
RESOLVED DUPLICATE of bug 143045
17 years ago
6 years ago

People

(Reporter: Thomas Thurman, Assigned: myk)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
The message "Only users in the selected groups can view this bug" on the 
default bug display and bug entry pages is confusing: it doesn't make it clear 
whether the flags are ANDed or ORed together. I suggest changing it to "A user 
must be a member of every group you tick below in order to view this bug:".
(Reporter)

Comment 1

17 years ago
Created attachment 71295 [details] [diff] [review]
Patch to 2.14.1 with new wording

The paths to the changed files might be non-standard: we're using the Debian
package.
thanks.  We are going to have to redo the patch, both of those files use
templates now, and I'm pretty sure that chunk of text is in the template, and
not in the CGI file anymore.
Priority: -- → P2
Target Milestone: --- → Bugzilla 2.18

Comment 3

16 years ago
The present wording (2.16rc1) is better:
./template/en/default/bug/edit.html.tmpl:
  <b>Only users in all of the selected groups can view this bug:</b>
./template/en/default/bug/create/create.html.tmpl:
  Only users in all of the selected groups can view this bug:

Should this still be changed? Or is this INVALID, FIXED or ...?
(Reporter)

Comment 4

16 years ago
That's an improvement. I think "A user must be a member of X to see this" is a 
little clearer than "Only users who are members of X can see this", but there's 
not much in it-- so it's probably okay to resolve this to FIXED now.

Comment 5

16 years ago
This is actually a duplicate of bug 143045, a patch for which was actually quite
recently checked in.
(Reporter)

Comment 6

16 years ago
Oh, neat. Thanks for finding that.

*** This bug has been marked as a duplicate of 143045 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 7

16 years ago
Hm, we have two patches now.

Comment 8

16 years ago
Reopening.  The patch for this bug includes a second change that
Bug 143045 does not.  However, the patch has bitrot now that
templates are in use, so I will mark it as needs-work.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Updated

16 years ago
Attachment #71295 - Flags: review-
Target Milestone: Bugzilla 2.18 → Bugzilla 2.20
Bugzilla 2.20 feature set is now frozen as of 15 Sept 2004.  Anything flagged
enhancement that hasn't already landed is being pushed out.  If this bug is
otherwise ready to land, we'll handle it on a case-by-case basis, please set the
blocking2.20 flag to '?' if you think it qualifies.
Target Milestone: Bugzilla 2.20 → Bugzilla 2.22
(In reply to comment #8)

Bug 143045 does include both changes.

*** This bug has been marked as a duplicate of 143045 ***
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago13 years ago
Resolution: --- → DUPLICATE
clearing target of DUPLICATE/WONTFIX/INVALID/WORKSFORME so they'll show up as
untriaged if they get reopened.
Target Milestone: Bugzilla 2.22 → ---
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.