Cookies are not being sent to white-listed sites

RESOLVED FIXED

Status

()

Core
Networking: Cookies
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Sudaraka Wijesinghe, Assigned: valentin)

Tracking

(Blocks: 1 bug, {regression})

49 Branch
x86_64
All
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox48 unaffected, firefox49+ fixed)

Details

(Whiteboard: [necko-active])

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20160524073714

Steps to reproduce:

Using nightly after May 25th, and a brand new profile

# Step 1
Visit http://www.whatarecookies.com/cookietest.asp

# Step 2
- Goto Preferences > Privacy
- Select "Use custom settings for history" option
- Uncheck "Accept cookies from sites"
- Visit http://www.whatarecookies.com/cookietest.asp

# Step 3
- Goto Preferences > Privacy
- Make sure "Accept cookies from sites" is NOT checked
- Click "Exceptions" button next to it
- Enter "http://www.whatarecookies.com/" in the "Address of website" box
- Click "Allow" button and then "Save Changes" button
- Visit http://www.whatarecookies.com/cookietest.asp


Actual results:

# Step 1
whatarecookies.com shows message "Cookies are ENABLED in this browser"

# Step 2
whatarecookies.com shows message "Cookies are DISABLED in this browser"

# Step 3
whatarecookies.com shows message "Cookies are DISABLED in this browser"


Expected results:

# Step 1
Got expected result

# Step 2
Got expected result

# Step 3
whatarecookies.com should shown message "Cookies are ENABLED in this browser". It seems when a cookies are disabled for all sites except for few white-listed ones, cookies are still being blocked for white-listed sites as well.
(Reporter)

Updated

2 years ago
OS: Unspecified → Linux
Hardware: Unspecified → x86_64

Comment 1

2 years ago
[Tracking Requested - why for this release]:
Status: UNCONFIRMED → NEW
status-firefox48: --- → unaffected
status-firefox49: --- → affected
tracking-firefox49: --- → ?
Component: Untriaged → Security: PSM
Ever confirmed: true
Keywords: regression
OS: Linux → All
Product: Firefox → Core

Comment 2

2 years ago
Regression window:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=5e25db36b720b695da94b2bc1373ea369408e404&tochange=6647b13a6ad92410d6a71298eded13ca655edbbe

Regressed by: Bug 219157


(I was surprised that in Firefox there is no automatic test!!)
Blocks: 219157
Component: Security: PSM → Networking: Cookies
Flags: needinfo?(mitchdevel)
(Assignee)

Comment 3

2 years ago
I'll backout the patches, while we finish up work in bug 219157.
Flags: needinfo?(mitchdevel)
Tracking this cookie regression for 49. In response to Alice's comment about a test in Comment 2, would it be possible for someone to write one?
tracking-firefox49: ? → +
Duplicate of this bug: 1276348
Assignee: nobody → valentin.gosu
Whiteboard: [necko-active]

Updated

2 years ago
Duplicate of this bug: 1276447
(Assignee)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
(Assignee)

Updated

2 years ago
Blocks: 1278011
Looks like this was fixed while 49 was on nightly, from comment 6.
status-firefox49: affected → fixed
You need to log in before you can comment on or make changes to this bug.