Closed Bug 1276537 Opened 5 years ago Closed 1 year ago

Remove pre-Lion (10.7) fullscreen logic

Categories

(Firefox :: Toolbars and Customization, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 78
Tracking Status
firefox49 --- wontfix
firefox78 --- fixed

People

(Reporter: MattN, Assigned: xidorn)

References

(Blocks 1 open bug)

Details

Attachments

(4 files)

Since support for 10.6-10.8 was dropped we can remove special code to implement custom fullscreen logic for 10.6 users which didn't have native fullscreen.

Some things I saw are:
* https://mxr.mozilla.org/mozilla-central/source/browser/themes/shared/browser.inc#7 (#restore-button)
* https://mxr.mozilla.org/mozilla-central/source/browser/base/content/browser.xul#976

but there is probably other places and it would be worth auditing browser-fullScreen.js.
Assignee: nobody → xidorn+moz
Status: NEW → ASSIGNED

I didn't find much pre-lion code in the files mentioned in comment 0 actually. Maybe I'm missing something...

Anyway https://treeherder.mozilla.org/#/jobs?repo=try&revision=25f0e6742ee2c299a940344241a95dd17a10fb92 hope it wouldn't break anything this time...

Duplicate of this bug: 1631641
Attachment #9147085 - Attachment description: Bug 1276537 part 1 - Remove widget code for compatiblity with pre-Lion macOS. r?spohl → Bug 1276537 part 2 - Remove nsIWidget::SetShowsFullScreenButton. r?spohl
Attachment #9147086 - Attachment description: Bug 1276537 part 2 - Remove OS X detection code from full screen handling. r?dao → Bug 1276537 part 3 - Remove OS X detection code from full screen handling. r?dao
Attachment #9147087 - Attachment description: Bug 1276537 part 3 - Remove now-useless fullscreenbutton attribute. r?dao → Bug 1276537 part 4 - Remove now-useless fullscreenbutton attribute. r?dao
Pushed by mozilla@upsuper.org:
https://hg.mozilla.org/integration/autoland/rev/7b2be27b7bb9
part 1 - Make resizable window on macOS always show full screen button. r=spohl
https://hg.mozilla.org/integration/autoland/rev/6d7fac080dca
part 2 - Remove nsIWidget::SetShowsFullScreenButton. r=spohl
https://hg.mozilla.org/integration/autoland/rev/d809b87c8868
part 3 - Remove OS X detection code from full screen handling. r=dao
https://hg.mozilla.org/integration/autoland/rev/ea043dfff6a6
part 4 - Remove now-useless fullscreenbutton attribute. r=dao
Regressions: 1638263
Regressions: 1638499
Regressions: 1644212
You need to log in before you can comment on or make changes to this bug.