ISO 8859-2 titles printing

VERIFIED WORKSFORME

Status

()

Core
Printing: Output
--
major
VERIFIED WORKSFORME
17 years ago
16 years ago

People

(Reporter: Pavel Janik, Assigned: rods (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020204
BuildID:    2002020415

When printing HTML page with ISO-8859-2 characters in the TITLE, mozilla
generates invalid PostScript:

GNU Ghostscript 6.51 (2001-03-28)
Copyright (C) 2001 artofcode LLC, Benicia, CA.  All rights reserved.
This software comes with NO WARRANTY: see the file COPYING for details.
Error: /undefined in Y~ύανι
Operand stack:

Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--  
--nostringval--   2   %stopped_push   --nostringval--   --nostringval--  
--nostringval--   false   1   %stopped_push   1   3   %oparray_pop   1   3  
%oparray_pop   1   3   %oparray_pop   .runexec2   --nostringval--  
--nostringval--   --nostringval--   2   %stopped_push   --nostringval--  
--nostringval--   --nostringval--
Dictionary stack:
   --dict:992/1241(ro)(G)--   --dict:0/20(G)--   --dict:66/200(L)--
Current allocation mode is local
Current file position is 216
GNU Ghostscript 6.51: Unrecoverable error, exit code 1

Deleting the line with %%Title works. 

Reproducible: Always
Steps to Reproduce:
1. open the page http://www.janik.cz/tmp/q.html
2. print it to file
3. gs mozilla.ps

You can use http://www.janik.cz/tmp/mozilla.ps as a sample output.

Actual Results:  see Description field - gs error.

Expected Results:  show the PostScript output ;-)

Comment 1

17 years ago
The example page is not valid - it lacks a matching "charset" directive which
sets ISO-8852-2 as page charset - can you fix that, please ?
(Reporter)

Comment 2

17 years ago
I fixed example page, but it does not matter for this particular problem.

Comment 3

16 years ago
just tried printing to file using linux trunk 2002041817 and get no such error.

Can you reproduce this in a recent nightly ( or 0.9.9 or 1.0rc1 ) ?

Comment 4

16 years ago
Reporter replied by e-mail:
---
0.9.9 is OK. Can you please enter that to bugzilla? I do not have web
access at the moment, only mail.
---

Marking worksforme
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 5

16 years ago
verified per comments.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.