Closed Bug 1276672 Opened 3 years ago Closed 3 years ago

browser_mozloop_telemetry.js creates a zombie process when running on windows7 VM

Categories

(Hello (Loop) :: Client, defect, P4)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: jmaher, Unassigned)

References

Details

Attachments

(1 file)

we are trying to move all our windows7 tests to run on a AWS VM instead of hardware in our datacenter.

This is going well, but a few tests are problematic.  In this case we get a zombiecheck failure in browser-chrome tests on opt tests (https://treeherder.mozilla.org/#/jobs?repo=try&revision=dfb24c916a3abf215ebc7de2e8c9d95e60648038) in this log file:
http://archive.mozilla.org/pub/firefox/try-builds/jmaher@mozilla.com-dfb24c916a3abf215ebc7de2e8c9d95e60648038/try-win32/try_win7_vm_test-mochitest-browser-chrome-1-bm139-tests1-windows-build85.txt.gz

I did a bunch of try pushes to bisect this down and found browser_mozLoop_telemetry.js to be the root cause of these zombie process issues.

I plan to disable this test for win7_opt, with the goal of it becoming undisabled in the near future.
Comment on attachment 8757942 [details] [diff] [review]
temporarily disable test for zombieleak failures

Review of attachment 8757942 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/extensions/loop/chrome/test/mochitest/browser.ini
@@ +17,5 @@
>  [browser_mozLoop_socialShare.js]
>  [browser_panel_privateBrowsing.js]
>  [browser_mozLoop_sharingListeners.js]
>  [browser_mozLoop_telemetry.js]
> +skip-if = os == win && !debug #  zombiecheck | child process 1228 still alive after shutdown (on win7-vm specifically)

Please add a bug number here.
Attachment #8757942 - Flags: review?(ryanvm) → review+
Pushed by jmaher@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/b780d702673a
disable browser_mozLoop_telemetry.js on win7_opt for zombieleak failures. r=RyanVM
Rank: 45
Priority: -- → P4
Blocks: 1281619
this test case is removed
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Removing leave-open keyword from resolved bugs, per :sylvestre.
Keywords: leave-open
You need to log in before you can comment on or make changes to this bug.